Bug 1000382 - bitronix.tm.internal.BitronixSystemException: cannot enlist more than one non-XA resource' error
bitronix.tm.internal.BitronixSystemException: cannot enlist more than one non...
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Core (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Maciej Swiderski
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 06:45 EDT by Marek Baluch
Modified: 2013-09-03 10:26 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 10:26:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reproducer (11.90 KB, application/zip)
2013-08-23 06:45 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-08-23 06:45:49 EDT
Created attachment 789552 [details]
reproducer

Description of problem:

on startProcess an exception is thrown with ${Summary} message.

The code

Configuration btm = TransactionManagerServices.getConfiguration();
btm.setAllowMultipleLrc(true);

fixes the issue but then an OptimisticLockException is thrown instead.


How to reproduce:
Using the attached file
1) mvn clean package
2) mvn exec:java
Comment 2 Maciej Swiderski 2013-09-03 10:18:54 EDT
Marek, the bitronix issue is caused by usage of old version of btm that does not work well with hibernate 4.2.0 and above. That's why we upgraded it to 3.0.0-SNAPSHOT - unfortunately snapshot as there is no final version for 3.0 available.

More details can be found here:
https://jira.codehaus.org/browse/BTM-126
http://bitronix-transaction-manager.10986.n7.nabble.com/Equality-of-PreparedStatement-td1448.html

I believe we can't do much about it then use btm 3.0.0-SNAPSHOT for now.

P.S.
The reproducer fails with java.lang.IndexOutOfBoundsException sure to process is only start and end but the reproducer tries to access tasks for user guest.
Comment 3 Marek Baluch 2013-09-03 10:26:30 EDT
Hi Maciej,

thanks for the info. Thanks for confirming my suspicion about the bitronix version! I will wait and/or use a db which should make it go away.

PS: Many thanks for doing QA to the reproducer :).

@M

Note You need to log in before you can comment on or make changes to this bug.