Bug 1000391 - Horizon: Cannot log-in. Exception Value: 'User' object has no attribute 'services_region'
Horizon: Cannot log-in. Exception Value: 'User' object has no attribute 'serv...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-openstack-auth (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity high
: beta
: 4.0
Assigned To: Ami Jeain
: Rebase, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 07:02 EDT by Gilles Dubreuil
Modified: 2013-12-19 19:21 EST (History)
5 users (show)

See Also:
Fixed In Version: python-django-openstack-auth-1.1.2-1.el6ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:21:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles Dubreuil 2013-08-23 07:02:07 EDT
Description of problem:
No user can ogin to Openstack Horizon dashboard.
In debug mode the message is:
Exception Value: 'User' object has no attribute 'services_region'

Version-Release number of selected component (if applicable):
python-django-horizon-2013.2-0.4.1b2.el6ost.noarch
python-django-openstack-auth-1.0.6-2.el6ost.noarch


Additional info:
The issue is know because an higher version of python-django-openstack-auth is required.

Workaround:
Using python-django-openstack-auth-1.0.11-1.el6.noarch.rpm from Havana/RDO.
Comment 2 Kevin Carter 2013-10-22 23:39:59 EDT
I wanted to confirm that this is still effecting package :

Name        : python-django-openstack-auth
Arch        : noarch
Version     : 1.1.2
Release     : 1.el6
Size        : 78 k
Repo        : installed
From repo   : epel-openstack


Running Horizon as a single server, in verbose mode with all settings yields this error:

[23/Oct/2013 03:17:04] "POST /auth/login/ HTTP/1.1" 403 1006


Horizon started with:
/usr/share/openstack-dashboard/manage.py runserver --insecure --settings=openstack_dashboard.settings --pythonpath=/usr/share/openstack-dashboard/ -v 3 --traceback x.x.x.x:80

This does not show any additional failures and or stack traces besides what was already mentioned.

Presently the workaround in downgrading the AUTH package does still work.
Comment 3 Matthias Runge 2013-10-23 02:52:27 EDT
Kevin, the last sentence makes me very suspicious, if you cleared your cookies after updating the package AND restarting httpd?
Comment 4 Kevin Carter 2013-10-24 16:43:47 EDT
Hey Matthias, thanks for the reply. It seems that when upgrading, which was what i was testing, all I needed to do was a simple restart of Apache. While I thought I had done that initially, it seems on m subsequent upgrade tests everything is working as expected. Thank you again.
Comment 5 Matthias Runge 2013-10-25 06:52:15 EDT
Kevin, glad it worked for you and the solution was that simple.
Comment 6 Scott Lewis 2013-11-19 11:54:35 EST
Auto adding >= MODIFIED bugs to beta
Comment 11 errata-xmlrpc 2013-12-19 19:21:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.