Bug 1000392 - Input on some screens is not persistent
Input on some screens is not persistent
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity medium
: CR1
: EAP 6.2.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 07:02 EDT by Petr Kremensky
Modified: 2014-09-03 00:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:15:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-08-23 07:02:25 EDT
There are some screens without persistent input. Next -> Previous or Previous -> Next operations will return screen to default state and erase any user changes. 
This makes domain socket binding screens really hard to use as user is unable to compare values he entered to different domain profiles.

JDK for quickstarts screen 
Pack selection screen
checkboxes on Socket Binding screen
Any input to Domain socket binding screens (all four profiles, standalone is OK)
browser launch checkbox on Server Launch screen
Comment 1 Miles Tjandrawidjaja 2013-08-26 11:28:06 EDT
Hello,

The issue has been patched.
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=30769c3df4618a77da21d7bf49d4c5a14df2eb7b

You should now see persistence on the
- JDK for quickstarts screen
- Pack selection screen
- Checkboxes on Socket Binding scree
- Any inpit to Domain socket binding screes
- Browser launch checkbox on Server Launch screen
Comment 2 Petr Kremensky 2013-08-27 03:46:46 EDT
Hi,
there will be no ER8. Changing target release to EAP 6.2.
Comment 3 Petr Kremensky 2013-09-13 06:26:16 EDT
Hi, please move BZs to ON_QA once the issue is fixed and target release is available so I can verify it. Thanks
Comment 4 Petr Kremensky 2013-09-18 06:23:54 EDT
Verified on EAP 6.2.0.ER2
Comment 6 Petr Kremensky 2013-09-23 11:08:45 EDT
I just find out that installation path is not persisted after moving to previous (Licence agreement) screen and back.
Comment 7 Miles Tjandrawidjaja 2013-09-27 16:33:38 EDT
Persistence added for target panel
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=eba8a73ed9a436cfcceebf403766cccfafd03966
Comment 9 Petr Kremensky 2013-10-07 10:27:33 EDT
There are still some fields we are missing. 
eg. "Security Realm Name" on second LDAP Configuration screen after going back to first LDAP screen and back. 

I'll go through all post-processing screens during ER5 cycle and give you full list of what should be fixed.
Comment 12 Petr Kremensky 2013-10-11 09:28:21 EDT
This issue occurs once user enter post-install summary screen. 

Reproduce:
 - go to Post-Install Configuration screen and select Install Infinispan Cache option
 - push next twice to get on Post-install summary screen, push previous to get back to Infinispan Configuration screen, now change some values (eg. Infinispan Name), push previous to get back to Post-Install Configuration screen, push next to go to Infinispan Configuration screen
Actual
 - changed values are not here
Expected
 - changes were persisted

I guess this is same for all post install configuration screens
Comment 13 Miles Tjandrawidjaja 2013-10-23 12:40:16 EDT
This regression has appeared due to requirements in the FSW installer.
In FSW there are panels that cannot be persistent under some cases.

We are discussing a solution to meet both requirements, it may take a lot of Izpack modifications.
Comment 14 Miles Tjandrawidjaja 2013-10-29 15:17:17 EDT
The EAP installer should now be persistent on all panels.

http://git.app.eng.bos.redhat.com/izpack.git/commit/?h=izpack-wip&id=ffacbd4bfd4ccdfcf501ffc873c83a7bd8631fea
Comment 15 Miles Tjandrawidjaja 2013-10-30 10:28:40 EDT
Fix will not be present in ER7, pushing to ER8.
Comment 16 Petr Kremensky 2013-10-31 06:45:47 EDT
Changing Target milestone to CR1. According to the latest information the next build will be CR1. There will be no more ER builds.
Comment 17 Petr Kremensky 2013-11-14 10:00:58 EST
Verified on EAP 6.2.0.CR1 installer.

Note You need to log in before you can comment on or make changes to this bug.