Bug 1000406 - [guided rule editor] Improve support for rule attributes/metadata
[guided rule editor] Improve support for rule attributes/metadata
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: manstis
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 07:55 EDT by Zuzana Krejčová
Modified: 2014-08-06 16:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:18:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
options in guided rule editor (19.26 KB, image/png)
2013-08-23 07:55 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-23 07:55:25 EDT
Created attachment 789573 [details]
options in guided rule editor

Description of problem:
The same option (attribute or metadata) can be added multiple times.
There is no input validation in the editor.
For attributes requiring a date, there should be a calendar pop-up to help choose a date.
Dialect should be a select box with only the supported values available.

See screenshot.

If you don't enter a string with whitespaces into salience input, validation then fails quietly on the data from the screenshot. There is an error in the server log stating that:
org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
Caused by: org.guvnor.common.services.shared.exceptions.GenericPortableException: Invalid date input format: [or a bit later] it should follow: [dd-MMM-yyyy]

If you don't have access to server log, you will never know that there is something wrong.


Version-Release number of selected component (if applicable):
6.0 ER1
Comment 1 manstis 2013-09-16 05:23:46 EDT
See https://bugzilla.redhat.com/show_bug.cgi?id=999904 too.
Comment 6 Zuzana Krejčová 2013-10-16 04:34:11 EDT
Most of this is fixed, so I'll mark this as verified.

Duplicate metadata issue is now covered by bug 1019665.

Note You need to log in before you can comment on or make changes to this bug.