Bug 1000447 - /usr/bin/openstack-db --init --service glance fails
/usr/bin/openstack-db --init --service glance fails
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-oslo-config (Show other bugs)
3.0
Unspecified Linux
urgent Severity low
: z2
: 3.0
Assigned To: Alan Pevec
Ami Jeain
: Regression, ZStream
Depends On: 997290
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 09:08 EDT by Scott Lewis
Modified: 2016-04-26 10:50 EDT (History)
13 users (show)

See Also:
Fixed In Version: python-oslo-config-1.1.0-3.el6ost
Doc Type: Bug Fix
Doc Text:
Previously in Glance, the "openstack-db --init" command failed when using the default configuration with an "unable to open database file" error. This was due to the location of files being incorrectly specified. This has been fixed and the Glance database is now correctly created and initialized.
Story Points: ---
Clone Of: 997290
Environment:
Last Closed: 2013-09-03 15:59:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Bruce Reeler 2013-08-28 02:00:19 EDT
NEEDINFO for Alan Pevec

I am writing the Doc Text for bug advisories. As the Doc Text field was blank, I have written the current Doc Text from scratch. Could you please comment or edit it and correct as necessary. Thanks.
Comment 3 Ami Jeain 2013-08-29 02:50:11 EDT
verified using:

# rpm -qa |grep openstack
kernel-firmware-2.6.32-358.118.1.openstack.el6.noarch
openstack-utils-2013.1-8.1.el6ost.noarch
openstack-packstack-2013.1.1-0.31.dev677.el6ost.noarch
kernel-2.6.32-358.118.1.openstack.el6.x86_64
openstack-glance-2013.1.3-1.el6ost.noarch

# rpm -qa |grep oslo
python-oslo-config-1.1.0-3.el6ost.noarch


# /usr/bin/openstack-db --init --service glance -p glance -r ""
mysqld is not running.  Would you like to start it now? (y/n): y
Initializing MySQL database:  Installing MySQL system tables...
OK
Filling help tables...
OK

To start mysqld at boot time you have to copy
support-files/mysql.server to the right place for your system

PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !
To do so, start the server, then issue the following commands:

/usr/bin/mysqladmin -u root password 'new-password'
/usr/bin/mysqladmin -u root -h cougar14.scl.lab.tlv.redhat.com password 'new-password'

Alternatively you can run:
/usr/bin/mysql_secure_installation

which will also give you the option of removing the test
databases and anonymous user created by default.  This is
strongly recommended for production servers.

See the manual for more instructions.

You can start the MySQL daemon with:
cd /usr ; /usr/bin/mysqld_safe &

You can test the MySQL daemon with mysql-test-run.pl
cd /usr/mysql-test ; perl mysql-test-run.pl

Please report any problems with the /usr/bin/mysqlbug script!

                                                           [  OK  ]
Starting mysqld:                                           [  OK  ]
Verified connectivity to MySQL.
Creating 'glance' database.
Initializing the glance database, please wait...
Complete!
Comment 4 Alan Pevec 2013-09-02 04:37:02 EDT
Relnote is good now.
Comment 5 errata-xmlrpc 2013-09-03 15:59:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1186.html

Note You need to log in before you can comment on or make changes to this bug.