Bug 1000509 - rhui-manager, sync a CDS options do not show the CDS or CDS clusters available
rhui-manager, sync a CDS options do not show the CDS or CDS clusters available
Status: CLOSED NOTABUG
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools (Show other bugs)
2.1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1.3
Assigned To: John Matthews
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 10:35 EDT by John Matthews
Modified: 2013-10-09 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 12:47:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2013-08-23 10:35:43 EDT
Description of problem:

Using rhui-manager I am trying to sync a CDS cluster and not seeing the CDS cluster displayed from the "sl" menu option.

------------------------------------------------------------------------------
             -= Red Hat Update Infrastructure Management Tool =-


-= Synchronization Status =-

   dr  display repo sync summary
   vr  view the details of the last repository sync
   sr  sync an individual repository immediately
   dc  display CDS sync summary
   vc  view the details of the last CDS sync
   sc  sync an individual CDS immediately
   sl  sync a CDS cluster immediately

                            Connected: ec2-50-16-54-43.compute-1.amazonaws.com
------------------------------------------------------------------------------
rhui (sync) => sl

Select one or more CDS clusters to schedule to be synchronized before its scheduled time.
The sync will happen as soon as possible depending on other tasks that may be executing
in the RHUI.  Only CDS clusters that currently do not have a CDS instance sychronizing are displayed.
         ------------------------------------------
Enter value (1-0) to toggle selection, 'c' to confirm selections, or '?' for more commands: 


Yet, if I view the CDS clusters I see the below



------------------------------------------------------------------------------
             -= Red Hat Update Infrastructure Management Tool =-


-= Content Delivery Server (CDS) Management =-

   l   list all CDS clusters and instances managed by the RHUI
   i   display detailed information on a CDS cluster
   a   register (add) a new CDS instance
   m   move CDS(s) to a different cluster
   d   unregister (delete) a CDS instance from the RHUI
   s   associate a repository with a CDS cluster
   u   unassociate a repository from a CDS cluster

                            Connected: ec2-50-16-54-43.compute-1.amazonaws.com
------------------------------------------------------------------------------
rhui (cds) => l

-= RHUI Content Delivery Server Clusters =-

  cluster1
  --------
    Content Delivery Servers
    -----------------------
    ec2-174-129-148-120.compute-1.amazonaws.com
    ec2-54-224-153-133.compute-1.amazonaws.com


------------------------------------------------------------------------------
rhui (cds) => 










Issue exists with "sync a single CDS as well".


------------------------------------------------------------------------------
             -= Red Hat Update Infrastructure Management Tool =-


-= Synchronization Status =-

   dr  display repo sync summary
   vr  view the details of the last repository sync
   sr  sync an individual repository immediately
   dc  display CDS sync summary
   vc  view the details of the last CDS sync
   sc  sync an individual CDS immediately
   sl  sync a CDS cluster immediately

                            Connected: ec2-50-16-54-43.compute-1.amazonaws.com
------------------------------------------------------------------------------
rhui (sync) => sc

Select one or more CDS instances to schedule to be synchronized before its scheduled time.
The sync will happen as soon as possible depending on other tasks that may be executing
in the RHUI. Only CDS instances that are not currently synchronizing are displayed.

         Last Result   Next Sync         Cluster            CDS
         ------------------------------------------------------

Enter value (1-0) to toggle selection, 'c' to confirm selections, or '?' for more commands: 








Version-Release number of selected component (if applicable):
rh-rhui-tools-2.1.19-1.el6.noarch
Comment 1 dgao 2013-09-27 17:14:58 EDT
John, sounds like the CDS cluster is already undergoing a sync. That's why it didn't show up under 'sl' or 'sc' command. Can you retest to confirm this is the case?
Comment 2 John Matthews 2013-10-09 12:47:11 EDT
Thanks Dave, agree the issue is I had a sync on-going at the time.

Moving to CLOSED

Note You need to log in before you can comment on or make changes to this bug.