Bug 1000546 - error: rpmdb open failed
error: rpmdb open failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:12cd9992d61c6d59b7efda3932f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 11:50 EDT by Javier Cabrera Córdoba
Modified: 2017-11-27 08:55 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-13 15:20:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (523.59 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: anaconda.log (47.48 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: environ (525 bytes, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: lsblk_output (2.90 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: messages (182.24 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: nmcli_dev_list (1.43 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: os_info (179 bytes, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: program.log (50.21 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: storage.log (210.41 KB, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: ifcfg.log (999 bytes, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details
File: packaging.log (54 bytes, text/plain)
2013-08-23 11:50 EDT, Javier Cabrera Córdoba
no flags Details

  None (edit)
Description Javier Cabrera Córdoba 2013-08-23 11:50:00 EDT
Description of problem:
Installing Fedora 19 from Live KDE Spin

Version-Release number of selected component:
anaconda-19.30.13-1.fc19.x86_64

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 602, in _setDefaultBootTarget
    if ts.dbMatch("provides", 'service(graphical-login)').count() and \
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/__init__.py", line 631, in postInstall
    self._setDefaultBootTarget()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/livepayload.py", line 147, in postInstall
    super(LiveImagePayload, self).postInstall()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 166, in doInstall
    payload.postInstall()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
error: rpmdb open failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-19-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
other involved packages: python-libs-2.7.5-1.fc19.x86_64
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Potential duplicate: bug 868755
Comment 1 Javier Cabrera Córdoba 2013-08-23 11:50:07 EDT
Created attachment 789638 [details]
File: anaconda-tb
Comment 2 Javier Cabrera Córdoba 2013-08-23 11:50:11 EDT
Created attachment 789639 [details]
File: anaconda.log
Comment 3 Javier Cabrera Córdoba 2013-08-23 11:50:15 EDT
Created attachment 789640 [details]
File: environ
Comment 4 Javier Cabrera Córdoba 2013-08-23 11:50:18 EDT
Created attachment 789641 [details]
File: lsblk_output
Comment 5 Javier Cabrera Córdoba 2013-08-23 11:50:23 EDT
Created attachment 789642 [details]
File: messages
Comment 6 Javier Cabrera Córdoba 2013-08-23 11:50:27 EDT
Created attachment 789643 [details]
File: nmcli_dev_list
Comment 7 Javier Cabrera Córdoba 2013-08-23 11:50:30 EDT
Created attachment 789644 [details]
File: os_info
Comment 8 Javier Cabrera Córdoba 2013-08-23 11:50:34 EDT
Created attachment 789645 [details]
File: program.log
Comment 9 Javier Cabrera Córdoba 2013-08-23 11:50:41 EDT
Created attachment 789646 [details]
File: storage.log
Comment 10 Javier Cabrera Córdoba 2013-08-23 11:50:44 EDT
Created attachment 789647 [details]
File: ifcfg.log
Comment 11 Javier Cabrera Córdoba 2013-08-23 11:50:48 EDT
Created attachment 789648 [details]
File: packaging.log
Comment 12 Steve Tyler 2013-08-23 16:07:48 EDT
Snippet from attached program.log:
...
10:28:00,778 INFO program: Running... rsync -pogAXtlHrDx --exclude /dev/ --exclude /proc/ --exclude /sys/ --exclude /run/ /mnt/install/source/ /mnt/sysimage
10:37:56,276 INFO program: cannot delete non-empty directory: var/run
10:37:56,277 INFO program: could not make way for new symlink: var/run
10:37:56,277 INFO program: rsync: rsync_xal_set: lremovexattr(""/mnt/sysimage/var/cache/yum"","security.selinux") failed: Permission denied (13)
10:37:56,278 INFO program: rsync: rsync_xal_set: lremovexattr(""/mnt/sysimage/var/lib/nfs/rpc_pipefs"","security.selinux") failed: Permission denied (13)
10:37:56,278 INFO program: rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1052) [sender=3.0.9]
10:37:56,278 DEBUG program: Return code: 23
...
Comment 13 David Shea 2014-03-04 10:41:29 EST
Does this problem still occur with F20? It looks like something wrote to /mnt/sysimage/var/run after the installation destination was mounted but before the payload install started. If this occurs again, can you tell us what is in /mnt/sysimage/var/run?

Note You need to log in before you can comment on or make changes to this bug.