Bug 1000552 - Google calendar appointments appear in all Google calendars
Google calendar appointments appear in all Google calendars
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 12:04 EDT by Matthew Saltzman
Modified: 2013-08-28 02:16 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.8.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 02:15:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2013-08-23 12:04:44 EDT
Description of problem:
After adding an appointment to the user's Google calendar, copies show up in Evo associated with all Google calendars the user is subscribed to.  Attempts to delete copies associated with read-only calendars are blocked.  The entries are not actually added to the real Google calendar.

Version-Release number of selected component (if applicable):
evolution-3.8.5-2.fc19.x86_64

How reproducible:
Always (I think)

Steps to Reproduce:
1. Create an online account associated with a Google account that is subscribed to multiple calendars.
2. Create an appointment in that account's primary Google calendar.
3.

Actual results:
Multiple copies of the appointment show up in Evo--one in each subscribed Google calendar.

Expected results:
One copy is created in the primary Google calendar.

Additional info:
Comment 1 Milan Crha 2013-08-26 05:10:02 EDT
Thanks for a bug report. I tried to reproduce this, but with no luck. I did:
a) configure a Google main calendar in evolution
b) configured a secondary Google calendar, which points to one public
   calendar which I'm subscribed to in Google's Web UI
c) opened a Day View and created an event in the main Google calendar

Result: an event is shown only once, within the main Google calendar.

Could it be that you have something misconfigured? I'm not sure where to look in detail, probably the underlying .source files may give a hint, and/or when starting `/usr/libexec/evolution-calendar-factory -w` from a console and see its output.
Comment 2 Matthew Saltzman 2013-08-27 15:19:49 EDT
Sure enough, I can no longer reproduce this.  Sorry to bother--we now return you to your regularly scheduled programming...

(I think I actually ran into this with the previous release. I was using my gmail calendar because I couldn't use my Exchange calendar.  With evolution-3.8.5-2.fc19.x86_64, both seem to be working as expected, so far.)
Comment 3 Milan Crha 2013-08-28 02:15:42 EDT
(In reply to Matthew Saltzman from comment #2)
> Sure enough, I can no longer reproduce this.  Sorry to bother--we now return
> you to your regularly scheduled programming...

No problem at all, I would really like to get the background what could break (I do not recall any bug being fixed for 3.8.5 which would be similar to your observation, which doesn't mean there was none), but as far as 3.8.5 works for you I'm fine.

Note You need to log in before you can comment on or make changes to this bug.