Bug 1000589 - Process compilation error stack does not include any information usable to identify the process definition which caused the error.
Process compilation error stack does not include any information usable to id...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER4
: 6.0.0
Assigned To: Kris Verlaenen
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 15:15 EDT by Marek Baluch
Modified: 2014-08-06 16:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
BPMS 6.0.0.ER1
Last Closed: 2014-08-06 16:10:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Baluch 2013-08-23 15:15:35 EDT
Description of problem:

The following stack trace (receive on build&deploy error) does not identify the process which contains the error.

21:07:35,092 ERROR [org.drools.compiler.kie.builder.impl.AbstractKieModule] (http-localhost/127.0.0.1:8080-6) Unable to build KieBaseModel:defaultKieBase
Error importing : 'com.bpms.flood.model.Request'
Error importing : 'com.bpms.flood.model.Person'
Process Compilation error : org.drools.compiler.lang.descr.ProcessDescr@686a5e23
	com/bpms/flood/Process_com_bpms_flood_RuleTask1407193470.java (2:31) : Only a type can be imported. com.bpms.flood.model.Request resolves to a package
	com/bpms/flood/Process_com_bpms_flood_RuleTask1407193470.java (4:93) : Only a type can be imported. com.bpms.flood.model.Person resolves to a package

Process Compilation error : org.drools.compiler.lang.descr.ProcessDescr@16ef5662
	com/bpms/flood/Process_com_bpms_flood_ManualTasks125951736.java (2:31) : Only a type can be imported. com.bpms.flood.model.Request resolves to a package
	com/bpms/flood/Process_com_bpms_flood_ManualTasks125951736.java (4:93) : Only a type can be imported. com.bpms.flood.model.Person resolves to a package

Error importing : 'com.bpms.flood.model.Person'
Error importing : 'com.bpms.flood.model.Request'

IMO a call to getProcessId() should be sufficient.
Comment 1 Mauricio Salatino 2013-08-23 15:43:00 EDT
I'm re assigning this bug to Michael Anstis, because the build and deploy button is on the Kie Project side, I hope that Michael can re assign the issue to the person responsible for that code.
Comment 3 Marek Baluch 2013-10-25 01:27:51 EDT
Verified on ER4.

Note You need to log in before you can comment on or make changes to this bug.