Bug 1000636 - NameError: global name 'logicals' is not defined
NameError: global name 'logicals' is not defined
Status: CLOSED DUPLICATE of bug 997711
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:9ad7c4be9c39fac8c4167e7c705...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-23 18:21 EDT by Adam Williamson
Modified: 2013-08-23 18:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-23 18:43:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (334.46 KB, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: anaconda.log (7.97 KB, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: environ (441 bytes, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: lsblk_output (2.10 KB, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: nmcli_dev_list (480 bytes, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: os_info (297 bytes, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: program.log (57.39 KB, text/plain)
2013-08-23 18:21 EDT, Adam Williamson
no flags Details
File: storage.log (217.70 KB, text/plain)
2013-08-23 18:22 EDT, Adam Williamson
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-08-23 18:22 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2013-08-23 18:21:31 EDT
Description of problem:
Testing anaconda 20.8, I hit this instead of the 'freeze at hub' bug, after returning from the partitioning spoke.

Version-Release number of selected component:
anaconda-20.8-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 439, in getDependentDevices
    for logical in logicals:
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1015, in deviceDeps
    return self.devicetree.getDependentDevices(device)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 743, in recursiveRemove
    devices = self.deviceDeps(device)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 392, in _scheduleActions
    self.storage.recursiveRemove(device)
NameError: global name 'logicals' is not defined

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=20130823-desktop-x86_64 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 slub_debug=- enforcing=0 BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.0-0.rc6.git2.1.fc21.x86_64
other involved packages: python-blivet-0.19-1.fc20.noarch
product:        Fedora
release:        Fedora release 21 (Rawhide)
type:           anaconda
version:        rawhide
Comment 1 Adam Williamson 2013-08-23 18:21:36 EDT
Created attachment 789744 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2013-08-23 18:21:39 EDT
Created attachment 789745 [details]
File: anaconda.log
Comment 3 Adam Williamson 2013-08-23 18:21:43 EDT
Created attachment 789746 [details]
File: environ
Comment 4 Adam Williamson 2013-08-23 18:21:47 EDT
Created attachment 789747 [details]
File: lsblk_output
Comment 5 Adam Williamson 2013-08-23 18:21:50 EDT
Created attachment 789748 [details]
File: nmcli_dev_list
Comment 6 Adam Williamson 2013-08-23 18:21:54 EDT
Created attachment 789749 [details]
File: os_info
Comment 7 Adam Williamson 2013-08-23 18:21:58 EDT
Created attachment 789750 [details]
File: program.log
Comment 8 Adam Williamson 2013-08-23 18:22:01 EDT
Created attachment 789751 [details]
File: storage.log
Comment 9 Adam Williamson 2013-08-23 18:22:06 EDT
Created attachment 789752 [details]
File: ifcfg.log
Comment 10 Brian Lane 2013-08-23 18:43:39 EDT

*** This bug has been marked as a duplicate of bug 997711 ***

Note You need to log in before you can comment on or make changes to this bug.