Bug 1000721 - opening url from terminal assumes it is a local file
opening url from terminal assumes it is a local file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mate-terminal (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 12:11 EDT by jonathan baron
Modified: 2013-08-26 05:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 05:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jonathan baron 2013-08-24 12:11:11 EDT
Description of problem:

Clicking on URL in a terminal window does not open URL, but rather tries to open file:///home/myname/'URL', with the URL in single quotes.

Version-Release number of selected component (if applicable):

This happens in all three terminals that allow this behavior:
gnome-terminal-3.8.4-1.fc19.x86_64
mate-terminal-1.6.1-11.fc19.x86_64
xfce4-terminal-0.6.2-1.fc19.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. put cursor over URL
2. right click
3. choose "Open Link"

Actual results:

described above. Browser (Firefox) can't find the URL.

Expected results:

URL opens.

Additional info:

If I choose "Copy Link Address" instead of "Open Link" the correct address is copied. I can then paste this into the location window of Firefox, and it opens properly.

I am surprised that nobody has reported this yet, so I investigated several features of my set-up to see if any of them might be at fault, but I cannot easily answer this. I did determine that it happens in both Firefox and Nightly.

I noticed that all three terminals depend on some of the same other files, namely pango, vte (vte3 for gnome), and gtk2 (3 for gnome) (and some others like glibc, which seem unlikely to be the source of the problem).

This started happening immediately after I upgraded from Fedora 18 to 19, a few days ago. It happens on three different computers.
Comment 1 Wolfgang Ulbrich 2013-08-26 03:47:55 EDT
I can't confirm this issue here in f19.
With all 3 terminals 'open link' works well from inside Mate session.
Which session you used?
Comment 2 jonathan baron 2013-08-26 05:23:51 EDT
I'm using Mate session. I had a feeling that this was something specific to my setup, so it probably isn't a bug, but I'm not closing it yet.

What is unusual about my setup is that I use Nightly, not Firefox, and somehow, several versions of Fedora ago (before I gave up on Gnome), I managed to set Nightly as the default browser, even though the entire program is in my /home/baron directory. Now I cannot find where that setting is. The dialog gives me a choice of Firefox or Google Chrome (not Opera or Nightly or ...), so clearly that isn't it. I've tried gconf-editor, dconf-editor, and some other things, but nothing I do seems to have any effect. Moreover, if I open Firefox, I get the same problem, so the default browser setting, whatever it is doesn't seem to do anything, because the problem occurs in Firefox.

I will fiddle around some more and report what I find before closing this bug report. Sorry for the trouble, and thanks for checking.
Comment 3 jonathan baron 2013-08-26 05:51:49 EDT
I Googled around and found where the default browser setting is:
/home/baron/.local/share/applications/preferred-web-browser.desktop
(Of course "baron" is my username, so you would have to replace that.)
It was set as
/home/baron/firefox/firefox %u
I removed the %u and then clicking a link just opened my home page.
I tried %s and the same thing happened.
I put back the %u, and now it works properly!
Go figure.

I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.