Bug 1000730 - "Disks" forgets the partition table type.
"Disks" forgets the partition table type.
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-disk-utility (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-24 14:04 EDT by Björn Persson
Modified: 2015-02-17 11:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:54:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn Persson 2013-08-24 14:04:15 EDT
Description of problem:
When working on a GPT-partitioned disk, "Disks" appears to forget what type of partition table it's working on, and fails to create another partition. Quite mysteriously, running Parted appears to restore "Disks" to a working state. 

Version-Release number of selected component (if applicable):
3.8.2-1.fc19

How reproducible:
No idea.

Steps to Reproduce:
1. Make a GUID Partition Table on an empty disk.
2. Create two partitions.
3. Try to create a third partition. A message box appears with the ungrammatical error message "Don't know how to create partitions this partition table of type `(null)' (udisks-error-quark, 0)". No partition is created. The partition table type is shown as "Unknown ()".
4. Try again with another filesystem type. Same result.
5. Exit "Disks" and restart it. Still not working.
6. List the partitions on the disk with Parted.
7. Start "Disks" again. Now the partition table type is shown as "GUID Partition Table" and a third partition can be created.
Comment 1 Fedora Admin XMLRPC Client 2014-05-01 10:46:26 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora End Of Life 2015-01-09 14:35:02 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2015-02-17 11:54:30 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.