This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1000835 - [abrt] calibre-1.0.0-1.fc19: main.py:7:<module>:ImportError: No module named apsw
[abrt] calibre-1.0.0-1.fc19: main.py:7:<module>:ImportError: No module named ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:102d40206ef4c0c58b62e760469...
:
: 1002009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-25 16:02 EDT by qwerty_144
Modified: 2013-08-28 10:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 10:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (7.13 KB, text/plain)
2013-08-25 16:02 EDT, qwerty_144
no flags Details
File: environ (1.19 KB, text/plain)
2013-08-25 16:02 EDT, qwerty_144
no flags Details

  None (edit)
Description qwerty_144 2013-08-25 16:02:22 EDT
Version-Release number of selected component:
calibre-1.0.0-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        python2 /usr/bin/calibre
executable:     /usr/bin/calibre
kernel:         3.10.9-200.fc19.i686
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib/calibre/calibre/gui2/main.py:7
#2 <module> in /usr/bin/calibre:19
Comment 1 qwerty_144 2013-08-25 16:02:27 EDT
Created attachment 790165 [details]
File: backtrace
Comment 2 qwerty_144 2013-08-25 16:02:30 EDT
Created attachment 790166 [details]
File: environ
Comment 3 Kevin Fenzi 2013-08-25 16:22:32 EDT
If you do a 'yum install python-apsw' does the problem persist?
Comment 4 Kerry 2013-08-26 03:09:49 EDT
Description of problem:
Started Calibre from command line

Version-Release number of selected component:
calibre-1.0.0-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        python2 /bin/calibre
executable:     /bin/calibre
kernel:         3.10.5-201.fc19.x86_64
runlevel:       N 3
type:           Python
uid:            500

Truncated backtrace:
#1 <module> in /usr/lib64/calibre/calibre/gui2/main.py:7
#2 <module> in /bin/calibre:19
Comment 5 Kerry 2013-08-26 03:24:29 EDT
Installing python-apsw fixed the problem for me.
Comment 6 Kevin Fenzi 2013-08-26 10:33:38 EDT
Fixed in rawhide, f20 branched and for f19/f18 in my side repo. 

Thanks for the report and sorry for the trouble...
Comment 7 Kevin Fenzi 2013-08-28 10:17:12 EDT
*** Bug 1002009 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.