Bug 10009 - date +%s returning tomorrows date in l2d
Summary: date +%s returning tomorrows date in l2d
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: time   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-06 14:58 UTC by jjohnson
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-06 15:15:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jjohnson 2000-03-06 14:58:15 UTC
using date +%s since March 01 returns tomorrows date when used in l2d on
the same system.  This happens in both my 6.0 and 6.1 systems.
Please verify and let me know if there is already a fix for this to
download.
thanks
Joe Johnson

Comment 1 Jeff Johnson 2000-03-06 15:15:59 UTC
What's l2d?

This program (compiled to ./xx)
	#include <stdio.h>
	main() { printf("%ld\n", (long)time(NULL)); }
verifies that there is not a problem in date(1) when invoked
	bash$ date '+%s' && ./xx
	952356119
	952356119


Note You need to log in before you can comment on or make changes to this bug.