Bug 1000922 - Dist-geo-rep : geo-rep config log-level option takes invalid values and makes geo-rep status defunct
Dist-geo-rep : geo-rep config log-level option takes invalid values and make...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ajeet Jha
Vijaykumar Koppad
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 02:42 EDT by Vijaykumar Koppad
Modified: 2015-02-22 18:01 EST (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Previously, the input for "log-level" configuration option of geop-replication was not validated. Now, an error message is displayed when user attempts to give invalid options.
Story Points: ---
Clone Of:
: 1010874 (view as bug list)
Environment:
Last Closed: 2013-11-27 10:32:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-08-26 02:42:20 EDT
Description of problem: The geo-rep config log-level option takes invalid values  and makes geo-rep status defunct. 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave config log-level Afafaef
geo-replication config updated successfully
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave status
NODE                       MASTER    SLAVE                      HEALTH     UPTIME       
------------------------------------------------------------------------------------
redlemon.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A          
redmoon.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redwood.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redcloud.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A  
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Problem with this is , it can't be recovered just by resetting it, you have to stop and start the session. 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave config \!log-level 
geo-replication config updated successfully
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave status
NODE                       MASTER    SLAVE                      HEALTH     UPTIME       
------------------------------------------------------------------------------------
redlemon.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A          
redwood.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redmoon.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redcloud.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>



Version-Release number of selected component (if applicable):glusterfs-3.4.0.22rhs-2.el6rhs.x86_64


How reproducible:happens everytime


Steps to Reproduce:
1.create and start a geo-rep relationship between master and slave. 
2.set config log-level to some random value
3.check the geo-rep status


Actual results: The geo-rep status becomes defunct 


Expected results:It should error out properly if it get wrong values.


Additional info:
Comment 2 Amar Tumballi 2013-09-24 03:32:04 EDT
upstream fix @ http://review.gluster.org/5989
Comment 3 Amar Tumballi 2013-10-07 02:39:58 EDT
https://code.engineering.redhat.com/gerrit/#/c/13677
Comment 4 Gowrishankar Rajaiyan 2013-10-08 04:41:31 EDT
Fixed in version please.
Comment 5 Vijaykumar Koppad 2013-10-15 05:56:36 EDT
verified on glusterfs-3.4.0.34rhs
Comment 7 errata-xmlrpc 2013-11-27 10:32:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.