This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1000925 - [abrt] bodhi-client-0.9.5-3.fc20: connectionpool.py:110:connect:ProxyError: Cannot connect to proxy. Socket error: [Errno -2] Name or service not known.
[abrt] bodhi-client-0.9.5-3.fc20: connectionpool.py:110:connect:ProxyError: C...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
abrt_hash:0364c10664a23e2ba9cbf0607d4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 02:54 EDT by Christopher Meng
Modified: 2016-09-19 22:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 16:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.38 KB, text/plain)
2013-08-26 02:54 EDT, Christopher Meng
no flags Details
File: dso_list (135 bytes, text/plain)
2013-08-26 02:54 EDT, Christopher Meng
no flags Details
File: environ (3.84 KB, text/plain)
2013-08-26 02:54 EDT, Christopher Meng
no flags Details

  None (edit)
Description Christopher Meng 2013-08-26 02:54:12 EDT
Description of problem:
VPN was stopped suddenly then I ctrl+c to end the bodhi and it sucked.

Version-Release number of selected component:
bodhi-client-0.9.5-3.fc20

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python -tt /usr/bin/bodhi --new --release f19 --file bodhi.template gnaural-1.0.20110606-1.fc19 --username cicku
executable:     /usr/bin/bodhi
kernel:         3.11.0-0.rc6.git3.2.fc21.i686+PAE
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
connectionpool.py:110:connect:ProxyError: Cannot connect to proxy. Socket error: [Errno -2] Name or service not known.

Traceback (most recent call last):
  File "/usr/bin/bodhi", line 523, in <module>
    main()
  File "/usr/bin/bodhi", line 220, in main
    data = bodhi.save(**update_args)
  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 111, in save
    'bugs': bugs,
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 344, in send_request
    auth_params=auth_params, retries=retries)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 351, in send_request
    verify=not self.insecure,
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 88, in post
    return request('post', url, data=data, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/api.py", line 44, in request
    return session.request(method=method, url=url, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 335, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 438, in send
    r = adapter.send(request, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/adapters.py", line 292, in send
    timeout=timeout
  File "/usr/lib/python2.7/site-packages/urllib3/connectionpool.py", line 459, in urlopen
    body=body, headers=headers)
  File "/usr/lib/python2.7/site-packages/urllib3/connectionpool.py", line 314, in _make_request
    conn.request(method, url, **httplib_request_kw)
  File "/usr/lib/python2.7/httplib.py", line 973, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib/python2.7/httplib.py", line 1007, in _send_request
    self.endheaders(body)
  File "/usr/lib/python2.7/httplib.py", line 969, in endheaders
    self._send_output(message_body)
  File "/usr/lib/python2.7/httplib.py", line 829, in _send_output
    self.send(msg)
  File "/usr/lib/python2.7/httplib.py", line 791, in send
    self.connect()
  File "/usr/lib/python2.7/site-packages/urllib3/connectionpool.py", line 110, in connect
    raise ProxyError('Cannot connect to proxy. Socket error: %s.' % e)
ProxyError: Cannot connect to proxy. Socket error: [Errno -2] Name or service not known.

Local variables in innermost frame:
self: <urllib3.connectionpool.VerifiedHTTPSConnection instance at 0x947074c>
e: gaierror(-2, 'Name or service not known')
Comment 1 Christopher Meng 2013-08-26 02:54:19 EDT
Created attachment 790306 [details]
File: backtrace
Comment 2 Christopher Meng 2013-08-26 02:54:23 EDT
Created attachment 790307 [details]
File: dso_list
Comment 3 Christopher Meng 2013-08-26 02:54:27 EDT
Created attachment 790308 [details]
File: environ
Comment 4 Luke Macken 2014-03-18 16:46:51 EDT
Are you able to reproduce this issue?
It looks like it's an intermittent proxy blip that is hopefully resolved now. Please re-open if you still experience this.

Note You need to log in before you can comment on or make changes to this bug.