Bug 1000936 - Quota: With quota disabled, shouldn't incur overheads of accounting or enforcing quota
Quota: With quota disabled, shouldn't incur overheads of accounting or enforc...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kaushal
Saurabh
: ZStream
Depends On: 1016019
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 03:20 EDT by Raghavendra Bhat
Modified: 2016-01-19 01:12 EST (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.38rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:32:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2013-08-26 03:20:31 EDT
Description of problem:

As of now, the code for operations done for accounting of quota is executed even though quota on the volume is disabled, thus affecting the performance. We need a mechanism where the accounting part is executed only when quota on the volume is enabled.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Raghavendra Bhat 2013-09-17 07:11:29 EDT
https://code.engineering.redhat.com/gerrit/#/c/11944/ has been submitted and mergedd.
Comment 4 krishnan parthasarathi 2013-09-23 05:44:56 EDT
The patch referred to in comment#3 made into to rhs-2.1 branch (and RHS-2.1 GA) as part of https://code.engineering.redhat.com/gerrit/#/c/12179/
Comment 5 shylesh 2013-09-30 06:07:20 EDT
[root@rhs-client4 mnt]# gluster v quota dist-rep disable
Disabling quota will delete all the quota configuration. Do you want to continue? (y/n) y
volume quota : success
[root@rhs-client4 mnt]#
[root@rhs-client4 mnt]#
[root@rhs-client4 mnt]# gluster v quota dist-rep limit-usage / 1GB
quota command failed : Quota is disabled, please enable quota
[root@rhs-client4 mnt]# gluster v quota dist-rep list /
quota command failed : Cannot list limits, quota is disabled
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                          1.0GB    (null)     953.7MB  70.3MB

#####
Quota disabled but still showing the accounting info
####

[root@rhs-client4 mnt]# gluster v quota dist-rep list /
quota command failed : Cannot list limits, quota is disabled
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                          1.0GB    (null)     953.7MB  70.3MB
[root@rhs-client4 mnt]#
[root@rhs-client4 mnt]# gluster v quota dist-rep enable
volume quota : success
[root@rhs-client4 mnt]# 
[root@rhs-client4 mnt]# 
[root@rhs-client4 mnt]# gluster v quota dist-rep list /
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                          1.0GB       80%       2.8GB  0Bytes
[root@rhs-client4 mnt]# gluster v quota dist-rep list 
quota: No quota configured on volume dist-rep



Though quota is not imposed after disabling but accounting info is still shown which should not, moving this bug back to "Assigned"
Comment 8 Kaushal 2013-10-28 02:02:41 EDT
The changes done for this bug till now, only fix the issues with 'quota list' listing older values when quota is disabled and enabled. But since quota xattrs set on the directories weren't being cleared, the quota accounting would happen again when quota was enabled.

The cleanup of xattrs is being tracked in bug-1016019 and the fix is on track to be included in update-1.

I'll leave this in ASSIGNED on my name for now, and will move it to ON_QA once the fix for 1016019 is merged and a build is released.
Comment 9 Kaushal 2013-11-06 23:18:17 EST
Moving this to ON_QA. Bug 1016019 has been fixed and the fixes are available in glusterfs-3.4.0.38rhs-1. With these fixes, there should be no more trouble with quotas remaining after being disabled.
Comment 11 Saurabh 2013-11-13 05:36:31 EST
moving this to verified
tried to test on glusterfs-3.4.0.43rhs-1
Comment 12 errata-xmlrpc 2013-11-27 10:32:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.