Bug 1000996 - quota build 3: soft-limit "A" message is completely wrong
quota build 3: soft-limit "A" message is completely wrong
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 05:38 EDT by Saurabh
Modified: 2016-01-19 01:15 EST (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Alert logs were being logged identifying with the files on which the writes were happening as opposed to being identified with the corresponding directory on which quota limit was set. Now, in this update, alert logs would be logged identifying with the directory on which quota limit is set, while file operations are being performed on files inside it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:33:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-08-26 05:38:03 EDT
Description of problem:
the "A" captured in the bricks logs are frequent, which for this build is a known limitation for this build
But a wrong and improper message is completely unacceptable.

Version-Release number of selected component (if applicable):
glusterfs-fuse-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-libs-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-api-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-server-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-3.4.0.20rhsquota5-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.20rhsquota5-1.el6rhs.x86_64


How reproducible:
always

Steps to Reproduce:
1. enable quota on volume
2. set limit of 1GB
3. mount volume on nfs
4. start creating data inside the mountpoint
   each file of size 1GB.
5. check brick logs.

Actual results:
[2013-08-26 06:18:57.767676] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497937
[2013-08-26 06:19:07.150637] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497947
[2013-08-26 06:19:12.731457] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497952
[2013-08-26 06:19:15.013489] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497955
[2013-08-26 06:19:16.612589] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497956
[2013-08-26 06:19:21.839714] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497962
[2013-08-26 06:19:42.568426] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497982
[2013-08-26 06:19:44.625484] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497984
[2013-08-26 06:19:46.553148] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497986

Expected results:
the soft limit as communicated to me is 80% of hard limit, hence it can't be 64KB, which is compeletly wrong and improper.

The messages are getting files, whereas the message should come for directories.


Additional info:
Comment 2 Raghavendra G 2013-08-26 21:23:20 EDT
Saurabh,

Was soft limit set on those directories which are mentioned in the logs? If not, following patch fixes the issue
 
https://code.engineering.redhat.com/gerrit/#/c/11948/

regards,
Raghavendra
Comment 3 Raghavendra G 2013-08-26 21:29:01 EDT
To put my question in a different way "Was hard limit set on those directories...?", since soft_limit is dependent on hard limit to be set.
Comment 4 Raghavendra G 2013-09-02 13:58:19 EDT
Sorry, this should have been needinfo. I wanted some additional information:

"To put my question in a different way "Was hard limit set on those directories...?", since soft_limit is dependent on hard limit to be set."
Comment 5 Saurabh 2013-09-02 23:16:18 EDT
As mentioned in the description section, I was getting "A" messages for files not for directories.

[2013-08-26 06:19:46.553148] A [quota.c:3350:quota_log_usage] 0-dist-rep3-quota: Usage is above soft limit: 64.0KB used by /1377497986

if you look into the above mentioned message, "/1377497986" was basically a file not a directory.
Comment 9 Gowrishankar Rajaiyan 2013-10-08 04:39:18 EDT
Fixed in version please.
Comment 11 errata-xmlrpc 2013-11-27 10:33:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.