Bug 1001013 - Cannot open Guided Decision Table with 2 WID files present
Cannot open Guided Decision Table with 2 WID files present
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER5
: 6.0.0
Assigned To: manstis
Radovan Synek
:
Depends On:
Blocks: 1001027
  Show dependency treegraph
 
Reported: 2013-08-26 06:12 EDT by Zuzana Krejčová
Modified: 2014-08-06 16:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: If you have two or more Work Item Definition files in your project, the system will not allow you to open any Guided Decision Tables in your project. Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error popup (17.04 KB, image/png)
2013-08-26 06:12 EDT, Zuzana Krejčová
no flags Details
server log excerpt (9.47 KB, text/x-log)
2013-08-26 06:13 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-26 06:12:54 EDT
Created attachment 790389 [details]
error popup

Description of problem:
If you have 2 (or more) Work Item Definition files present, you cannot open any Guided Decision Table in your project due to:

Unable to complete your request. The following exception occurred: java.util.HashMap cannot be cast to java.util.List.

Until you delete both(!) WIDs, you won't be able to get to any GDT.


Version-Release number of selected component (if applicable):
6.0 ER1


Steps to Reproduce:
1. Create 2 (valid) WIDs.
2. Create a new (or open an already existing) Guided Decision Table.
3. Wait for the editor.


Actual results:
Editor pane is empty, error popup shown instead.


Expected results:
Editor shown with the correct content, no error.
Comment 1 Zuzana Krejčová 2013-08-26 06:13:49 EDT
Created attachment 790390 [details]
server log excerpt

Error as shown in the server log.
Comment 6 Radovan Synek 2013-10-16 10:20:15 EDT
Update for ER4:
The issue still persists, the malicious work item definition is the default one (generated when new .bpmn2 process definition is created). When this WID exists in a project, no guided decision table can be opened in this project.

error message when opening the GDT: Unable to complete your request. The following exception occured: java.util.ArrayList cannot be cast to java.util.Map.
Comment 7 Radovan Synek 2013-10-16 10:46:58 EDT
I have found out that having only "Log" work item in the definition is sufficient to reproduce the issue:

import org.drools.core.process.core.datatype.impl.type.StringDataType;

[
   [
    "name" : "Log",
    "parameters" : [
      "Message" : new StringDataType()
    ],
    "displayName" : "Log",
    "icon" : "defaultlogicon.gif"
  ]
]
Comment 8 manstis 2013-10-17 07:11:25 EDT
I've made "New Work Item Definition" (and the default template) work consistently with the Work Item Definitions generated with a new process.
Comment 10 Radovan Synek 2013-12-03 05:22:16 EST
Verified on BRMS-6.0.0.ER5

Note You need to log in before you can comment on or make changes to this bug.