Bug 1001118 - grub2 does not install /boot/efi/EFI/BOOT/BOOTx64.EFI on UEFI system
grub2 does not install /boot/efi/EFI/BOOT/BOOTx64.EFI on UEFI system
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
x86_64 Other
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 10:14 EDT by Michael Brown
Modified: 2013-08-26 11:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 11:09:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Brown 2013-08-26 10:14:46 EDT
Description of problem: grub2 does not install /boot/efi/EFI/BOOT/BOOTx64.EFI
on an Intel DH77KC system board.

Version-Release number of selected component (if applicable):
grub2-install (GRUB) 2.00

How reproducible: Perform a clean installation of Fedora on a UEFI system with Legacy BIOS disabled if applicable.


Steps to Reproduce:
1. Select default installation options
2. Reclaim space if required, auto-partition
3. Allow installation to finish and reboot

Actual results:
system unbootable

Expected results:
system unbootable

How to fix: Copy /boot/efi/EFI/fedora/grubx64.efi to /boot/efi/EFI/BOOT/BOOTX64.EFI

(I don't believe it's case sensitive)


Additional info:

http://wiki.osdev.org/UEFI#Booting

Apologies if this is filed incorrectly, it's my first bug report.

boot partitions (snipped):

(gdisk -l)
Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          411647   200.0 MiB   EF00  EFI System Partition
   2          411648         1435647   500.0 MiB   0700  

(parted -l)
Number  Start   End    Size   File system  Name                  Flags
 1      1049kB  211MB  210MB  fat16        EFI System Partition  boot
 2      211MB   735MB  524MB  ext4

I noticed Anaconda creates fat16 instead of fat32.
Comment 1 Mads Kiilerich 2013-08-26 10:23:07 EDT
That is by design. That location is only intended for (re)movable bootable media. On normal EFI systems the firmware EFI bootloader should let the user choose or be configured in nvram to point at the fedora folder by default.
Comment 2 Michael Brown 2013-08-26 10:50:42 EDT
see:

https://bugzilla.redhat.com/show_bug.cgi?id=624873

and "... section 3.4.1.2 of the spec, which specifies that in the absence of any configured boot variables it is permitted for the firmware to treat the EFI system partition in the same way as removable media - that is, it'll boot EFI/boot/bootx64.efi or whatever." (source: http://mjg59.dreamwidth.org/4125.html)
Comment 3 Michael Brown 2013-08-26 10:53:16 EDT
Sorry I forgot to add, befire I copied bootx64.efi, efibootmgr listed the following:

BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0000

After it displayed:

BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0000,0001
Boot0000* Fedora
Boot0001* UEFI : SATA : PORT 6G 0 : Corsair Neutron GTX SSD : PART 0 : OS
Comment 4 Michael Brown 2013-08-26 11:09:38 EDT
removed bootx64.efi and system now boots fine with the Fedora entry. will contact Intel regarding possible firmware issue

Note You need to log in before you can comment on or make changes to this bug.