Bug 1001219 - Switchyard subsystem exists on non-SOA EAP
Switchyard subsystem exists on non-SOA EAP
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: JON (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER3
: 6.0.0
Assigned To: kconner
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 15:04 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-08-26 15:04:00 EDT
Description of problem: I have switchyard plugin installed and I imported pure EAP6 running in Domain mode. I can see SwitchYard subsystems down under both of managed servers under my EAP. It looks like there is an incorrect selector in switchyard plugin descriptor.

Similar thing happens to Standalone Server, SwitchYard subsystem appears here as well, but seems to be UP.


Version-Release number of selected component (if applicable):
RHQ 4.9-master switchyard plugin master

How reproducible: always


Steps to Reproduce:
1. install switchyard plugin
2. inventory EAP6 in domain mode (with 2 managed servers started by default)
3. inventory EAP6 in standalone mode

Actual results: SwitchYard subsystem appears (DOWN) under running managed servers, SwitchYard subsystem appears UP under standalone server


Expected results: SwitchYard subsystem should not appear on any other EAP6 based product but SOA.
Comment 2 kconner 2013-09-18 15:59:35 EDT
The SwitchYard subsystem now only appears for servers which contain the SwitchYard component, from tag 1.0.0-redhat-2 onwards
Comment 3 Libor Zoubek 2013-10-04 04:16:09 EDT
verified on JON 3.2.ER2

Note You need to log in before you can comment on or make changes to this bug.