Bug 1001225 - missing requires sysfsutils
missing requires sysfsutils
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openstack-cinder (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Eric Harney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-26 15:29 EDT by Itamar Reis Peixoto
Modified: 2013-11-26 16:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 16:21:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Reis Peixoto 2013-08-26 15:29:34 EDT
Description of problem:


I am seeing in compute.log

2013-08-26 15:22:48.727 WARNING nova.virt.libvirt.utils [req-d41d02a0-1b94-4bbe-b9af-532e1de723ef 4a0fc355865f4524bd4364f3205ddd6e 4fe8bfda212442bb81aef8be5f5e18a1] systool is not installed
2013-08-26 15:22:48.784 WARNING nova.virt.libvirt.utils [req-d41d02a0-1b94-4bbe-b9af-532e1de723ef 4a0fc355865f4524bd4364f3205ddd6e 4fe8bfda212442bb81aef8be5f5e18a1] systool is not installed


systool is not installed


I think some packages needs sysfsutils packages, please fix it adding it to requires.
Comment 1 Pádraig Brady 2013-08-27 14:30:41 EDT
So this dependency was added to nova folsom in:
https://review.openstack.org/#/c/19992/

Since cinder is now handling all volume stuff,
perhaps upstream needs to remove some of this, or at least keep quiet about it?

Does cinder need a hard dependency on sysfsutils for fc support?
I'm thinking it does.
Comment 2 Fedora Update System 2013-08-29 14:11:41 EDT
openstack-cinder-2013.1.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openstack-cinder-2013.1.3-1.fc19
Comment 3 Fedora Update System 2013-09-07 20:31:36 EDT
openstack-cinder-2013.1.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.