Bug 1001299 - ECC signature not always padded correctly.
ECC signature not always padded correctly.
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: coolkey (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity high
: rc
: 7.1
Assigned To: Bob Relyea
Asha Akkiangady
:
: 1035438 (view as bug list)
Depends On:
Blocks: 1113520 1035437 1035438
  Show dependency treegraph
 
Reported: 2013-08-26 16:39 EDT by Jack Magne
Modified: 2015-02-25 06:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1035437 1035438 (view as bug list)
Environment:
Last Closed: 2014-09-26 18:53:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix to padd incoming ECC signatures correctly. (2.69 KB, patch)
2013-08-26 16:39 EDT, Jack Magne
no flags Details | Diff

  None (edit)
Description Jack Magne 2013-08-26 16:39:34 EDT
Created attachment 790689 [details]
Fix to padd incoming ECC signatures correctly.

Description of problem:

Now that we can make ECC signatures, this requires often that the signature data has to be padded or truncated correctly based on what is returned by the card and what is required by NSS.

We already have a method to do this but it only handles the truncation case, not the padding case.


Version-Release number of selected component (if applicable):

Latest rhel5 coolkey


How reproducible:

Always.

Steps to reproduce.

1. Enroll a 384 bit or higher token with rhcs ecc upcoming errata candidate.

2. Run BobR's smartcard test program.




Actual results:

Some of the signatures attempted by the tool will fail.

Expected results:

We want all support signature types to be performed correctly.
Comment 1 Suzanne Forsberg 2013-08-29 10:22:57 EDT
Since 5.10 is only accepting blocker bugs at this point(they have already built a release candidate), I am recommending that we defer this fix until 5.11 and we consider fixing this in 5.10.z.
Comment 2 Bob Relyea 2013-11-26 20:36:03 EST
Jack please clone this bug for RHEL6 (target 6.6) and RHEL 7
Comment 3 RHEL Product and Program Management 2014-01-22 11:26:40 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 Asha Akkiangady 2014-07-17 15:11:10 EDT
*** Bug 1035438 has been marked as a duplicate of this bug. ***
Comment 8 Bob Relyea 2014-09-26 18:53:17 EDT
tested on RHEL 7 as well. Padding is working correctly.

Note You need to log in before you can comment on or make changes to this bug.