This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001308 - FEAT: expresscard test should use dmidecode data to plan expresscard test
FEAT: expresscard test should use dmidecode data to plan expresscard test
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rob Landry
Red Hat Kernel QE team
:
Depends On:
Blocks: 1001233
  Show dependency treegraph
 
Reported: 2013-08-26 17:00 EDT by Rob Landry
Modified: 2013-11-13 04:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1001311 1012070 (view as bug list)
Environment:
Last Closed: 2013-11-13 04:56:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to use dmidecode as an expresscard slot detection (1.36 KB, patch)
2013-09-24 14:17 EDT, Rob Landry
no flags Details | Diff

  None (edit)
Description Rob Landry 2013-08-26 17:00:36 EDT
Description of problem:

Currently the expresscard test uses battery + pcie + usb to say there is probably an expresscard slot.  At least recent versions of dmidecode provide expresscard data, though it must be researched which versions in RHEL6.x provide this and which versions provide correct information and how often some set of laptop vendors properly populate this field. 


Additional info:

From a Lenovo X220

[rlandry@unused ~]$ rpm -qf /etc/redhat-release
redhat-release-server-6Server-6.4.0.4.el6.x86_64


[rlandry@unused ~]$ uname -a
Linux unused 2.6.32-358.el6.x86_64 #1 SMP Tue Jan 29 11:47:41 EST 2013 x86_64 x86_64 x86_64 GNU/Linux


[root@unused ~]# rpm -q dmidecode
dmidecode-2.11-2.el6_1.x86_64


Handle 0x0027, DMI type 9, 17 bytes
System Slot Information
        Designation: ExpressCard Slot
        Type: x1 PCI Express
        Current Usage: Available
        Length: Other
        ID: 1
        Characteristics:
                Hot-plug devices are supported
        Bus Address: 0000:00:00.0



...My understanding is the x1 is referring to the capabilities of the slot, and the fact that there is only a single entry is referring to there being a single slot.
Comment 1 Rob Landry 2013-09-24 14:17:20 EDT
Created attachment 802418 [details]
patch to use dmidecode as an expresscard slot detection

I couldn't find what object we're storing the dmidecode data in the harness, it didn't look like we were so I just added a new call.  This over time should probably just be part of the hardware dictionary object?  Also I only added detection but from the output I think we could look for multiple stanza's with express card, and use the count of those as the number of expresscard slots.  Unfortunately I have no way to test that as my box only has a single slot
Comment 5 Brian Brock 2013-10-08 10:55:49 EDT
Patch appears to be present, and expresscard at least partially pass.  Tests with the USB expresscard pass as expected, tests for pcie on expresscard fail due to lack of a peripheral.  Will retry later with a drive attached.
Comment 11 errata-xmlrpc 2013-11-13 04:56:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html

Note You need to log in before you can comment on or make changes to this bug.