Bug 1001446 - Traditional Chinese not listed in language menu of installer Welcome dialog
Traditional Chinese not listed in language menu of installer Welcome dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 01:12 EDT by Steve Tyler
Modified: 2013-11-06 04:54 EST (History)
13 users (show)

See Also:
Fixed In Version: anaconda-20.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 04:54:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing "Simplified Chinese (China)" in Welcome dialog (100.67 KB, image/png)
2013-08-27 01:12 EDT, Steve Tyler
no flags Details
screenshot showing "Traditional Chinese (Republic of China)" in F19 languages menu (95.83 KB, image/png)
2013-08-27 01:48 EDT, Steve Tyler
no flags Details
localization-test-report-20_08_1.txt (1.64 KB, text/plain)
2013-08-27 09:07 EDT, Steve Tyler
no flags Details
localization-test-4.py unit test (1.42 KB, text/plain)
2013-08-27 09:09 EDT, Steve Tyler
no flags Details
chinese-variants-in-language-selection-f20-beta-tc6.png (97.87 KB, image/png)
2013-10-28 11:18 EDT, Mike FABIAN
no flags Details
This is the screenshot (97.87 KB, image/png)
2013-10-30 00:44 EDT, Cheng-Chia Tseng
no flags Details
chinese-variants-in-language-selection-f20-beta-rc3.png (96.99 KB, image/png)
2013-11-05 15:14 EST, Mike FABIAN
no flags Details

  None (edit)
Description Steve Tyler 2013-08-27 01:12:24 EDT
Created attachment 790762 [details]
screenshot showing "Simplified Chinese (China)" in Welcome dialog

Description of problem:
The language menu in the installer Welcome dialog lists "Simplified Chinese (China)", but it does not list Traditional Chinese.

Version-Release number of selected component (if applicable):
anaconda 20.8-1
Fedora-20-Alpha-TC1-x86_64-DVD.iso

How reproducible:
Always.

Steps to Reproduce:
1. Start installer from DVD:
$ qemu-kvm -m 4096 -hda f20-test-3.img -cdrom ~/xfr/fedora/F20/Alpha/Fedora-20-Alpha-TC1-x86_64-DVD.iso -vga std -boot menu=on

Actual results:
"Simplified Chinese (China)" is listed.
Traditional Chinese is not listed.
See attached screenshot.

Expected results:
Both Simplified Chinese and Traditional Chinese are listed.

Additional info:
Comment 1 Steve Tyler 2013-08-27 01:41:37 EDT
Langtable does not have "Traditional Chinese (Taiwan)" in English.[1]

The locale is:
$ locale -a | grep zh_TW
zh_TW
zh_TW.big5
zh_TW.euctw
zh_TW.utf8

There is a translation for anaconda:
$ find /usr/share/locale/ -name anaconda.mo | grep zh
/usr/share/locale/zh_TW/LC_MESSAGES/anaconda.mo
/usr/share/locale/zh_CN/LC_MESSAGES/anaconda.mo

[1] Searches find these:
$ grep -i chinese langtable-0.0.11/data/languages.xml | grep -i traditional
      <name><languageId>en</languageId><trName>Traditional Chinese (Hong Kong)</trName></name>
      <name><languageId>en</languageId><trName>Traditional Chinese</trName></name>
      <name><languageId>zu</languageId><trName>isi-Traditional Chinese</trName></name>
      <name><languageId>en</languageId><trName>Traditional Chinese (Macau SAR China)</trName></name>
      <name><languageId>en</languageId><trName>Traditional Chinese (Republic of China)</trName></name>

$ grep -i taiwan langtable-0.0.11/data/languages.xml
      <name><languageId>de</languageId><trName>Traditionelles Chinesisch (Taiwan)</trName></name>
Comment 2 Steve Tyler 2013-08-27 01:48:03 EDT
Created attachment 790771 [details]
screenshot showing "Traditional Chinese (Republic of China)" in F19 languages menu
Comment 3 Steve Tyler 2013-08-27 01:58:06 EDT
OK, zh_TW is in langtable with the name "Traditional Chinese (Republic of China)":

$ less -N langtable-0.0.11/data/languages.xml
...
  21270   <language>
  21271     <languageId>zh_TW</languageId>
...
  21275     <names>
  21276       <name><languageId>de</languageId><trName>Traditionelles Chinesisch (Taiwan)</trName></name>
  21277       <name><languageId>en</languageId><trName>Traditional Chinese (Republic of China)</trName></name>
...
  21284     </names>
  21285     <locales>
  21286       <locale><localeId>zh_TW.UTF-8</localeId><rank>1000</rank></locale>
  21287     </locales>
...
  21300   </language>
...
Comment 4 Parag Nemade 2013-08-27 02:05:47 EDT
Yes its there. I too noticed that different kind of naming for both Chinese languages (for its country name) in langtable.

Simplified Chinese (China)
and
Traditional Chinese (Republic of China)
Comment 5 Steve Tyler 2013-08-27 02:41:12 EDT
CCing Cheng-Chia Tseng, who opened this bug for the same problem in F18:
Bug 858801 - [zh_TW] Please add Chinese (Taiwan) language to language selection menu in anaconda
Comment 6 Mike FABIAN 2013-08-27 03:57:50 EDT
(In reply to Steve Tyler from comment #5)
> CCing Cheng-Chia Tseng, who opened this bug for the same problem in F18:
> Bug 858801 - [zh_TW] Please add Chinese (Taiwan) language to language
> selection menu in anaconda

F18 didn’t use langtable though, so whatever was the problem in F18, it
must have been something differnent.
Comment 7 Mike FABIAN 2013-08-27 03:59:47 EDT
(In reply to Parag from comment #4)
> Yes its there. I too noticed that different kind of naming for both Chinese
> languages (for its country name) in langtable.
> 
> Simplified Chinese (China)
> and
> Traditional Chinese (Republic of China)

The different naming for the territory name is intentional.
Comment 8 Mike FABIAN 2013-08-27 04:10:26 EDT
The f19 screenshot

https://bugzilla.redhat.com/attachment.cgi?id=790771

looks correct to me, I think we only have a problem in f20.
Comment 9 Mike FABIAN 2013-08-27 04:36:12 EDT
mfabian@ari:~
$ python
Python 2.7.5 (default, Aug 22 2013, 09:31:58) 
[GCC 4.8.1 20130603 (Red Hat 4.8.1-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import langtable
>>> from langtable import language_name
>>> print language_name("zh")
中文
>>> print language_name("zh_CN")
简体中文 (中国)
>>> print language_name("zh_TW")
繁體中文 (台灣)
>>> print language_name(languageId="zh", territoryId="CN")
简体中文 (中国)
>>> print language_name(languageId="zh", territoryId="CN", languageIdQuery="zh")
中文 (中国)
>>> print language_name(languageId="zh", territoryId="TW", languageIdQuery="zh")
繁体中文 (台湾)
>>> print language_name(languageId="zh", territoryId="TW", languageIdQuery="zh_CN")
繁体中文 (中华民国)
>>> print language_name(languageId="zh", territoryId="TW", languageIdQuery="zh_TW")
繁體中文 (台灣)
>>> 
mfabian@ari:~
$ rpm -q langtable
langtable-0.0.11-1.fc21.noarch
mfabian@ari:~
$
Comment 10 Mike FABIAN 2013-08-27 04:40:13 EDT
There was no significant change in langtable for these names recently.

So I think on f19, Anaconda uses 

>>> print language_name("zh_CN")
简体中文 (中国)
>>> print language_name("zh_TW")
繁體中文 (台灣)

and on f20 it uses only

>>> print language_name(languageId="zh", territoryId="CN", languageIdQuery="zh")
中文 (中国)
>
Comment 11 Vratislav Podzimek 2013-08-27 05:38:06 EDT
This seems to be an Anaconda issue. However, the welcome screen is going to be changed a lot for the Fedora 20 (dealing with this bug, among the other things).
Comment 12 Steve Tyler 2013-08-27 09:07:45 EDT
Created attachment 790971 [details]
localization-test-report-20_08_1.txt

Attached is a list of locales returned by get_available_translations().

zh_CN is listed, but not zh_TW.

$ cat localization-test-report-20_08_1.txt | egrep 'L:   n:|zh'
L:   n: locale              
L:  72: zh_CN.UTF-8

Command line:
$ ./localization-test-4.py localization_20_08_1.py > localization-test-report-20_08_1.txt

Testing is with F19:
$ rpm -q langtable python
langtable-0.0.6-1.fc19.noarch
python-2.7.5-4.fc19.x86_64
Comment 13 Steve Tyler 2013-08-27 09:09:40 EDT
Created attachment 790972 [details]
localization-test-4.py unit test
Comment 14 Cheng-Chia Tseng 2013-08-27 10:49:52 EDT
(In reply to Mike FABIAN from comment #8)
> The f19 screenshot
> 
> https://bugzilla.redhat.com/attachment.cgi?id=790771
> 
> looks correct to me, I think we only have a problem in f20.

Yeah, f19 lists Traditional Chinese correctly.
Comment 15 Steve Tyler 2013-08-27 11:11:17 EDT
(In reply to Cheng-Chia Tseng from comment #14)
> (In reply to Mike FABIAN from comment #8)
> > The f19 screenshot
> > 
> > https://bugzilla.redhat.com/attachment.cgi?id=790771
> > 
> > looks correct to me, I think we only have a problem in f20.
> 
> Yeah, f19 lists Traditional Chinese correctly.

Thanks. Are the country names OK?
Comment 16 Cheng-Chia Tseng 2013-08-27 11:31:39 EDT
(In reply to Steve Tyler from comment #15)
> (In reply to Cheng-Chia Tseng from comment #14)
> > (In reply to Mike FABIAN from comment #8)
> > > The f19 screenshot
> > > 
> > > https://bugzilla.redhat.com/attachment.cgi?id=790771
> > > 
> > > looks correct to me, I think we only have a problem in f20.
> > 
> > Yeah, f19 lists Traditional Chinese correctly.
> 
> Thanks. Are the country names OK?

The country names are OK (both in Traditional Chinese and English) too in f19.
Comment 17 Vratislav Podzimek 2013-08-29 08:27:05 EDT
A small temporary patch posted to anaconda-patches.
Comment 18 Steve Tyler 2013-08-29 16:17:03 EDT
(In reply to Vratislav Podzimek from comment #17)
> A small temporary patch posted to anaconda-patches.

Thanks. The patch fixes this bug.

I've attached a full report here: Bug 1001801, Comment 3:
Bug 1001801 - some languages missing from language menu in Welcome dialog
Comment 19 Steve Tyler 2013-09-04 17:24:27 EDT
This is not fixed with the 20-Alpha-TC3 DVD.
The DVD has anaconda 20.9-1, not 20.10-1[1].

Tested with:
$ qemu-kvm -m 4096 -hda f20-test-3.img -cdrom ~/xfr/fedora/F20/Alpha/Fedora-20-Alpha-TC3-x86_64-DVD.iso -vga std -boot menu=on

[1] https://fedorahosted.org/rel-eng/ticket/5745#comment:9
Comment 20 Mike FABIAN 2013-10-28 11:18:58 EDT
Created attachment 816842 [details]
chinese-variants-in-language-selection-f20-beta-tc6.png

It works in Fedora-20-Beta-TC6-x86_64-DVD.iso.
Comment 21 Cheng-Chia Tseng 2013-10-30 00:44:06 EDT
Created attachment 817271 [details]
This is the screenshot

I have just verified Fedora-Live-Desktop-x86_64-20-Beta-TC6 that traditional Chinese is listed.

However, the display name of traditional Chinese in Taiwan (zh_TW) should be "繁體中文 (台灣)" in traditional Chinese variant form instead of "繁体中文 (台湾)" in simplified Chinese variant form. The situation of traditional Chinese in Hong Kong is the same, using simplified Chinese variant to display the name.
Comment 22 Mike FABIAN 2013-10-30 03:06:17 EDT
(In reply to Cheng-Chia Tseng from comment #21)
> Created attachment 817271 [details]
> This is the screenshot
> 
> I have just verified Fedora-Live-Desktop-x86_64-20-Beta-TC6 that traditional
> Chinese is listed.
> 
> However, the display name of traditional Chinese in Taiwan (zh_TW) should be
> "繁體中文 (台灣)" in traditional Chinese variant form instead of "繁体中文 (台湾)" in
> simplified Chinese variant form. The situation of traditional Chinese in
> Hong Kong is the same, using simplified Chinese variant to display the name.

Ah, yes, you are right.

Seems to be correct in langtable though, trying to figure out how
anaconda uses it to make this happen...
Comment 23 Mike FABIAN 2013-10-30 07:37:32 EDT
Test cases from langtable:

    >>> print(language_name(languageId="zh", territoryId="TW", languageIdQuery="zh")) # doctest: +NORMALIZE_WHITESPACE
        繁体中文 (台湾)

    >>> print(language_name(languageId="zh", territoryId="TW", languageIdQuery="zh", territoryIdQuery="TW")) # doctest: +NORMALIZE_WHITESPACE
        繁體中文 (台灣)

    >>> print(language_name(languageId="zh", territoryId="TW", languageIdQuery="zh", territoryIdQuery="CN")) # doctest: +NORMALIZE_WHITESPACE
        繁体中文 (中华民国)

Vratislav Podzimek found the problem in anaconda (not using
territoryIdQuery), he’ll fix it soon.
Comment 24 Mike FABIAN 2013-11-05 15:14:49 EST
Created attachment 820006 [details]
chinese-variants-in-language-selection-f20-beta-rc3.png

Fixed in Fedora-20-Beta-RC3-x86_64-netinst.iso, see screenshot.

Thank you, Vratislav!

Note You need to log in before you can comment on or make changes to this bug.