This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001493 - mdadm segfault when failing to write metadata
mdadm segfault when failing to write metadata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mdadm (Show other bugs)
6.3
All Linux
urgent Severity high
: rc
: ---
Assigned To: Jes Sorensen
huan-zhang
: ZStream
Depends On: 950545
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 03:22 EDT by Libor Miksik
Modified: 2014-02-16 17:25 EST (History)
13 users (show)

See Also:
Fixed In Version: mdadm-3.2.5-4.el6_4.2
Doc Type: Bug Fix
Doc Text:
* Previously, mdadm could have experienced a segmentation fault if it encountered a write error while attempting to write a superblock onto a defective drive. This his been corrected in this update so that mdadm no longer crashes if the aforementioned scenario occurs.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 09:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Miksik 2013-08-27 03:22:07 EDT
This bug has been copied from bug #950545 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 huan-zhang 2013-09-09 03:23:32 EDT
According to comment 6.
We have no h/w and hard to simulate.
Regression test passed.
SanityOnly.
Comment 9 errata-xmlrpc 2013-09-11 09:00:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1257.html

Note You need to log in before you can comment on or make changes to this bug.