Bug 1001511 - Power Management: suspend when laptop lid close should be easily configurable
Power Management: suspend when laptop lid close should be easily configurable
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-tweak-tool (Show other bugs)
7.0
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Rui Matos
Desktop QE
: Regression, Reopened
Depends On:
Blocks: 995392 1077854 1078323
  Show dependency treegraph
 
Reported: 2013-08-27 04:08 EDT by Ondrej Hudlicky
Modified: 2014-06-18 04:20 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 976834
: 1077854 (view as bug list)
Environment:
Last Closed: 2014-06-13 06:10:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Bastien Nocera 2013-09-20 08:43:32 EDT
Copy pasting the comments in bug 976834:
---8<---
It's the way we've always handled things by default at least, but the move to systemd to handle suspend and inhibition means that we need to do more work on the power plugin side. Re-adding the code would complicate already very complicated code for not much gain, since there are alternatives.

There's also a funny tool for your particular use case:
http://www.hadess.net/2011/09/omg-i-haz-designed-bug-fix.html

office-runner is being reviewed in Fedora at:
https://bugzilla.redhat.com/show_bug.cgi?id=998238

You can also modify /etc/systemd/logind.conf to read:
HandleLidSwitch=ignore

So that lid closure aren't taken into account. You can also inhibit suspend for a period of time, or while a particular application is running by doing:
systemd-inhibit --what=handle-lid-switch sleep 3600

Finally, there might also be a gnome-shell extension for this.

I'll close this, as we won't be bringing back the option, as alternatives are already available.
---8<---
Comment 2 Petr Šplíchal 2013-10-07 08:02:00 EDT
Thanks for providing the workaround, Bastien. I agree with Ondrej
that this is an important usability issue as this is quite common
use case. So I would vote for adding back a user friendly way how
to disable the suspend. However, if we really do not want to get
this functionality back, this definitely has to be documented. I
do not see any reference to release notes or other documentation
in the closing comment ---> thus reopening the bug to track this.
Comment 3 Vladimir Benes 2013-10-07 08:35:53 EDT
can we get this to gnome-tweak-tool option?
Comment 4 Bastien Nocera 2013-10-07 13:36:32 EDT
Reassigning to gnome-tweak-tool
Comment 5 Bastien Nocera 2013-11-04 10:22:04 EST
(In reply to Petr Šplíchal from comment #2)
> Thanks for providing the workaround, Bastien. I agree with Ondrej
> that this is an important usability issue as this is quite common
> use case.

FWIW, I don't think it's a common use case, or a valid one (it's usually working around deficiencies in integration from various applications), otherwise it would be catered for in the main UI, not relegated to config files.
Comment 6 Matthias Clasen 2014-01-31 12:13:05 EST
discussed a plan with rui for having a toggle in gnome-tweak-tool.
Comment 7 Rui Matos 2014-02-04 04:47:40 EST
gnome-tweak-tool-3.8.1-7.el7 contains a switch labeled "Don't suspend on lid close" which should fix this issue.
Comment 11 Ludek Smid 2014-06-13 06:10:15 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.