Bug 1001551 - unable to unselect Kickstart Details -> Operating System -> Repositories:
unable to unselect Kickstart Details -> Operating System -> Repositories:
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
560
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Jan Hutař
:
Depends On:
Blocks: sat560-blockers
  Show dependency treegraph
 
Reported: 2013-08-27 05:29 EDT by Jan Hutař
Modified: 2013-10-01 17:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:57:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-08-27 05:29:03 EDT
Description of problem:
I have a KS profile and each time I unselect additional repositories they gets selected again.


Version-Release number of selected component (if applicable):
Compose 20130822


How reproducible:
always (tired on both Oracle and PostgreSQL satellite variant)


Steps to Reproduce:
1. Create KS profile. I have used these values but not sure if that matters:
   Base Channel*: RHEL6 x86_64 Server channel
   Kickstartable Tree*: RHEL6-U4 one
   Virtualization Type: None
2. In webUI go to <your_kickstart> -> Kickstart Details -> Operating System
3. Note that "Repositories" are all unselected
4. Check them all and click "Update Kickstart"
5. Note that "Repositories" are all selected
6. Uncheck them all and click "Update Kickstart"
7. Note that "Repositories" are all selected again


Actual results:
At the end, repositories are all checked although I have just unchecked them


Expected results:
Repositories should be in the state (checked vs. unchecked) as user decides or explanation error message why he can not do it should be displayed


Additional info:
I have tested this on 5.5.0 Satellite and there it works as expected
Comment 1 Tomas Lestach 2013-08-27 08:19:42 EDT
Right, this was caused by me (22f7bef1). Fixing ...

spacewalk.git: 37cc54e56789baa8f8954195028bc2fad5f7eb44
Comment 5 Clifford Perry 2013-10-01 17:57:00 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.