This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001608 - rpc.mountd start fail exit, but not output any warn/error info to user.
rpc.mountd start fail exit, but not output any warn/error info to user.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.4
All Linux
medium Severity high
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
:
Depends On: 1001605
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 07:41 EDT by Yin.JianHong
Modified: 2016-03-28 15:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1001605
Environment:
Last Closed: 2016-03-28 15:19:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-08-27 07:41:46 EDT
+++ This bug was initially created as a clone of Bug #1001605 +++

Description of problem:
rpc.mountd start fail exit, but not output any warn/error info to user.

Version-Release number of selected component (if applicable):
RedHatEnterpriseWorkstation 7.0
nfs-utils-1.2.8-2.0.el7.x86_64


How reproducible:


Steps to Reproduce:
1. rpc.mountd -o 1
2.
3.

Actual results:
[root@dhcp12-125 ~]# rpc.mountd -o 1
[root@dhcp12-125 ~]# echo $?
1


Expected results:
[root@dhcp12-125 ~]# rpc.mountd -o 1
<some error info>
[root@dhcp12-125 ~]# echo $?
1


Additional info:
follow code can cover more code branch:

case $(lsb_release -sr) in 5.*) max=5;; 6.*) max=19;; 7.*) max=10;; esac
for n in `seq 1 $max`; do
    std=$(rpc.mountd $args $n 2>&1)
    [ $? != 0 ] && {
        test -n "$std" || echo "rpc.mountd start fail, but not output any info"
    }
done
Comment 1 Yin.JianHong 2013-08-27 07:45:01 EDT
In RHEL5, no this issue;  happens in In RHEL6 RHEL7
Comment 3 RHEL Product and Program Management 2013-10-13 22:32:26 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Steve Dickson 2016-03-28 15:19:43 EDT
(In reply to Yongcheng Yang from comment #4)
> Issue still exist in latest nfs-utils-1.2.3-68.el6
> 
> [root@hp-dl380eg8-03 ~]# rpc.mountd -o 1
> [root@hp-dl380eg8-03 ~]# echo $?
> 1
> [root@hp-dl380eg8-03 ~]# rpm -q nfs-utils
> nfs-utils-1.2.3-68.el6.x86_64
> [root@hp-dl380eg8-03 ~]#
Setting the number of possible open file descriptor to 
not a valid set up... self-induced... not a bug.

Note You need to log in before you can comment on or make changes to this bug.