Bug 1001611 - /usr/bin/ld.gold crashes trying to build Thunderbird trunk from source code
/usr/bin/ld.gold crashes trying to build Thunderbird trunk from source code
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 07:47 EDT by Jonathan Kamens
Modified: 2013-08-27 08:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 08:06:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
End of the Thunderbird build log (326.55 KB, text/plain)
2013-08-27 07:47 EDT, Jonathan Kamens
no flags Details
Backtrace from /usr/bin/ld.gold (35.25 KB, text/plain)
2013-08-27 07:47 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2013-08-27 07:47:07 EDT
Created attachment 790925 [details]
End of the Thunderbird build log

I was trying to compile the Thunderbird trunk from source code. It failed with the error shown in the attached build-tail.log. Further analysis indicates a crash in /usr/bin/ld.gold (binutils-2.23.52.0.1-9.fc19.x86_64). I've attached a backtrace of the trash. I'm filing it by hand rather than with ABRT because ABRT fails to analyze the backtrace (I filed a separate bug about that).
Comment 1 Jonathan Kamens 2013-08-27 07:47:36 EDT
Created attachment 790926 [details]
Backtrace from /usr/bin/ld.gold
Comment 2 Jonathan Kamens 2013-08-27 08:06:35 EDT
NVM, the problem was that I have a 6GB memory limit set on processes when I'm logged in, and this particular ld invocation actually required more than 6GB of RAM. Lovely.

Note You need to log in before you can comment on or make changes to this bug.