Bug 1001616 - win7-64 guest bsod while enter s3/s4 state with virtio scsi
win7-64 guest bsod while enter s3/s4 state with virtio scsi
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 08:04 EDT by mazhang
Modified: 2014-01-01 11:34 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:34:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of bsod (191.40 KB, image/png)
2013-08-27 23:18 EDT, mazhang
no flags Details
screenshot of bsod (s3) (212.97 KB, image/png)
2013-08-28 01:44 EDT, mazhang
no flags Details
memory dump of s4 (16.00 KB, text/plain)
2013-08-28 05:15 EDT, mazhang
no flags Details

  None (edit)
Description mazhang 2013-08-27 08:04:34 EDT
Description of problem:
win7-64 guest bsod after do s4

Version-Release number of selected component (if applicable):
host:
qemu-kvm-0.12.1.2-2.398.el6.x86_64
kernel:2.6.32-414.el6.x86_64

guest: win7-64
virtio-win-prewhql-0.1-67


How reproducible:
100%

Steps to Reproduce:
1.CLI
#/usr/libexec/qemu-kvm \
-M pc \
-cpu Opteron_G4 \
-m 2G \
-smp 4,sockets=2,cores=2,threads=1,maxcpus=16 \
-enable-kvm \
-name win7 \
-uuid 990ea161-6b67-47b2-b803-19fb01d30d12 \
-smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67170 \
-k en-us \
-rtc base=localtime,clock=host,driftfix=slew \
-no-kvm-pit-reinjection \
-monitor stdio \
-boot menu=on \
-bios /usr/share/seabios/bios.bin \
-netdev tap,id=hostnet0,downscript=no,vhost=on \
-device virtio-net-pci,netdev=hostnet0,id=net0 \
-qmp tcp:0:6666,server,nowait \
-nodefconfig \
-nodefaults \
-drive file=/home/win7-64.raw,if=none,id=drive-scsi-disk,format=raw,cache=none,werror=stop,rerror=stop \
-device virtio-scsi-pci,id=scsi0 \
-device scsi-disk,drive=drive-scsi-disk,bus=scsi0.0,scsi-id=0,lun=0,id=scsi-disk,bootindex=1 \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-vga qxl \
-spice port=5900,disable-ticketing \

2.start->shut down->hibernate


Actual results:
guest bsod

Expected results:
works well

Additional info:
will attach the dump file later.
Comment 2 mazhang 2013-08-27 08:25:20 EDT
virtio block cant hit this problem
Comment 4 mazhang 2013-08-27 23:17:07 EDT
1. It just happened with virtio scsi disk, if remove nic and use ide works well.

2. Guest didn't generate dump file, whatever set to 'Complete memory dump' 'Kernel memory dump' or 'minidump'
Comment 5 mazhang 2013-08-27 23:18:54 EDT
Created attachment 791235 [details]
screenshot of bsod
Comment 6 mazhang 2013-08-28 01:43:24 EDT
try enter s3 state with virtio scsi also hit this problem.
Comment 7 mazhang 2013-08-28 01:44:33 EDT
Created attachment 791259 [details]
screenshot of bsod (s3)
Comment 8 mazhang 2013-08-28 05:15:12 EDT
Created attachment 791285 [details]
memory dump of s4
Comment 9 mazhang 2013-08-28 05:17:50 EDT
dump file can't be write on disk, so boot guest with ide drive and attach a virtio scsi storage. 
guest enter s4 state , then qemu-kvm quit. boot guest again, guest bsod and got memory dump.
dump file has been analyze and attached in comment 8 .
Comment 12 Mike Cao 2013-08-30 02:57:57 EDT
Not sure whether it is related ,but could you try with -cpu Opteron_G4,family=0xe ?
Comment 13 mazhang 2013-08-30 03:08:58 EDT
still hit this problem with -cpu Opteron_G4,family=0xe.
Comment 15 Vadim Rozenfeld 2013-08-31 03:39:23 EDT
*** Bug 996951 has been marked as a duplicate of this bug. ***
Comment 16 Vadim Rozenfeld 2013-09-07 23:59:08 EDT
please re-check with build 69 available at https://brewweb.devel.redhat.com/buildinfo?buildID=293655

Thanks
Vadim.
Comment 17 mazhang 2013-10-08 23:08:29 EDT
Verify this bug with virtio-win-prewhql-0.1-72 .

[root@ibm-x3100m4-02 ~]# rpm -qa |grep qemu
qemu-kvm-0.12.1.2-2.409.el6.x86_64
qemu-kvm-debuginfo-0.12.1.2-2.409.el6.x86_64
qemu-img-0.12.1.2-2.409.el6.x86_64
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
qemu-kvm-tools-0.12.1.2-2.409.el6.x86_64

CLI:
/usr/libexec/qemu-kvm \
-M pc \
-cpu SandyBridge \
-m 2G \
-smp 4,sockets=2,cores=2,threads=1,maxcpus=16 \
-enable-kvm \
-name win7 \
-uuid 990ea161-6b67-47b2-b803-19fb01d30d12 \
-smbios type=1,manufacturer='Red Hat',product='RHEV Hypervisor',version=el6,serial=koTUXQrb,uuid=feebc8fd-f8b0-4e75-abc3-e63fcdb67170 \
-k en-us \
-rtc base=localtime,clock=host,driftfix=slew \
-no-kvm-pit-reinjection \
-monitor stdio \
-boot menu=on \
-bios /usr/share/seabios/bios.bin \
-netdev tap,id=hostnet0,downscript=no,vhost=on \
-device e1000,netdev=hostnet0,id=net0 \
-qmp tcp:0:6666,server,nowait \
-nodefconfig \
-nodefaults \
-global PIIX4_PM.disable_s3=0 \
-global PIIX4_PM.disable_s4=0 \
-vga qxl \
-spice port=5900,disable-ticketing \
-drive file=/home/win7-64.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none,aio=threads \
-device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 \
-drive file=/home/storage.qcow2,if=none,id=drive-scsi-disk,format=qcow2,cache=none,werror=stop,rerror=stop \
-device virtio-scsi-pci,id=scsi0 \
-device scsi-disk,drive=drive-scsi-disk,bus=scsi0.0,scsi-id=0,lun=0,id=scsi-disk \


steps refer to comment#0 .

Guest s3/s4 works well, no bsod.
Comment 18 Vadim Rozenfeld 2013-10-09 00:35:33 EDT
Thanks,
Can we move it to verified?

Cheers,
Vadim.
Comment 19 Mike Cao 2013-10-09 01:15:42 EDT
Move status to VERIFIED based on comment#17

Note You need to log in before you can comment on or make changes to this bug.