Bug 1001704 - Restarting VDSM results in traffic duplication on a NIC with port mirroring
Restarting VDSM results in traffic duplication on a NIC with port mirroring
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
medium Severity medium
: ---
: 3.3.0
Assigned To: Antoni Segura Puimedon
GenadiC
network
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-08-27 10:38 EDT by tgeft
Modified: 2016-02-10 14:58 EST (History)
9 users (show)

See Also:
Fixed In Version: is17
Doc Type: Bug Fix
Doc Text:
When attaching a NIC to a virtual machine, port mirroring was part of the process regardless of whether it was a newly created virtual machine, or if the NIC was attached to the virtual machine after VDSM restart. Consequently, port mirroring was reapplied as many times as VDSM was restarted. Now, port mirroring is only set when attaching the NIC to a virtual machine that is not in a recovery process, so virtual machine port mirroring is only set as many times as intended by the user.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:14:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (7.11 MB, text/x-log)
2013-08-27 11:03 EDT, tgeft
no flags Details
supervdsm log (5.44 MB, text/x-log)
2013-08-27 11:11 EDT, tgeft
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19534 None None None Never

  None (edit)
Description tgeft 2013-08-27 10:38:55 EDT
Description of problem:
On a setup containing a VM with port mirroring, restarting VDSM will result in traffic duplication on the NIC with port mirroring.


Version-Release number of selected component (if applicable):
vdsm-4.12.0-72.git287bb7e.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
A setup with 3 VMs on the same network.

1. Enable port mirroring on one of the VMs (using a profile with port mirroring on its VNIC)
2. Restart VDSM
3. Send traffic between the two VMs without port mirroring.
4. Monitor the traffic on the VM with port mirroring (for example using tcpdump on the interface with port mirroring).

Actual results:
The traffic between the two VMs without port mirroring will be duplicated on the monitoring machine. That is, each packet will be captured twice.

Expected results:
The traffic should not be duplicated.

Additional info:
Each subsequent restart to VDSM will increase the number of duplicate packets.

To stop the duplication, one would need to unplug and plug the NIC with port mirroring.
Comment 1 tgeft 2013-08-27 11:03:18 EDT
Created attachment 791044 [details]
vdsm log
Comment 2 tgeft 2013-08-27 11:11:55 EDT
Created attachment 791063 [details]
supervdsm log
Comment 6 Meni Yakove 2013-10-01 09:37:12 EDT
vdsm-4.12.0-170.el6ev.x86_64
Comment 7 Charlie 2013-11-27 19:31:48 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 errata-xmlrpc 2014-01-21 11:14:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.