Bug 1001706 - We must notify user that X windows is needed in order to connect to engine VM.
We must notify user that X windows is needed in order to connect to engine VM.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 10:44 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.5.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:52:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18930 None None None Never
oVirt gerrit 19369 None None None Never
oVirt gerrit 19680 None None None Never
oVirt gerrit 19687 None None None Never

  None (edit)
Description Leonid Natapov 2013-08-27 10:44:40 EDT
After creating VM ovirt-hosted-engine setup notifies user that he/she can connect to VM using the following command: 

You can now connect to the VM with the following command: /usr/bin/remote-viewer vnc://localhost:5900

If user makes a local installation X Windows packages must be installed in order to open remote-viewer. If  user connects to host using ssh he must use ssh -X command and have xauth installed on the server. We must notify user about that.
Comment 1 Itamar Heim 2013-08-28 02:17:15 EDT
we can also provide virtio-console / console access to qemu serial on local machine?
Comment 2 Sandro Bonazzola 2013-09-02 04:56:18 EDT
(In reply to Itamar Heim from comment #1)
> we can also provide virtio-console / console access to qemu serial on local
> machine?

CCing Alex that have already looked into virtio-console issues.
Comment 3 Sandro Bonazzola 2013-09-06 08:59:25 EDT
Added a note remembering to the user that remote-viewer is
a graphical application.
Comment 7 Sandro Bonazzola 2013-09-18 10:29:43 EDT
(In reply to Itamar Heim from comment #1)
> we can also provide virtio-console / console access to qemu serial on local
> machine?

Found a way for enabling the virsh console using devices keyword in vm.conf, reopening the bug
Comment 8 Sandro Bonazzola 2013-09-18 10:32:42 EDT
patch pushed upstream master.
Add console device to the Hosted Engine VM definition.
Allows to connect to the VM without X.
Added a note in the same dialog where we remind that X is needed for remote-viewer.
Comment 9 Sandro Bonazzola 2013-09-19 11:10:49 EDT
patch 19369 merged upstream master.
Comment 10 Sandro Bonazzola 2013-09-26 02:46:57 EDT
From Tim Hildred in http://gerrit.ovirt.org/18930

> Sorry I'm late the the party, I was on PTO for a couple of weeks. I have two comments:

>    We sell RHEV as "easy to use" to shops that generally use windows. As it is, the reminder is essentially meaningless to Windows admins: "Please note that in order to use remote-viewer you need to be able to run graphical applications."
>    Be specific about what your users need. This would be better: "In order to use the remote-viewer client to connect to and control your hosted-engine virtual machine, the hosted-engine virtual machine requires software allowing graphical applications to run. At the very least, you need the following packages installed on your hosted-engine virtual machine to allow remote-viewer connections:{insert required packages here}"

It make sense.

>    my other comment: there is no mention of console connections in this code. Is that on purpose?

Console has been added in another patch: http://gerrit.ovirt.org/19369
Comment 11 Sandro Bonazzola 2013-09-30 08:14:37 EDT
(In reply to Sandro Bonazzola from comment #10)

> >    We sell RHEV as "easy to use" to shops that generally use windows. As it is, the reminder is essentially meaningless to Windows admins: "Please note that in order to use remote-viewer you need to be able to run graphical applications."
> >    Be specific about what your users need. This would be better: "In order to use the remote-viewer client to connect to and control your hosted-engine virtual machine, the hosted-engine virtual machine requires software allowing graphical applications to run. At the very least, you need the following packages installed on your hosted-engine virtual machine to allow remote-viewer connections:{insert required packages here}"
> 
> It make sense.

Well, Tim has misunderstood here, it's not the VM that needs graphical support, it's the host. 
Here is the new message (including the virtual console):

 Please note that in order to use remote-viewer you need to be able to run graphical applications.
 This means that if you are using ssh you have to supply the -Y flag (enables trusted X11 forwarding).
 Otherwise you can run the command from a terminal in your preferred desktop environment.
 If you cannot run graphical applications you can connect to the graphic console from another host or connect to the console using the following command:
 virsh -c qemu+tls://{host}/system console HostedEngine

where {host} is automatically filled.
Comment 12 Sandro Bonazzola 2013-09-30 09:10:56 EDT
patch merged upstream master and 1.0
Comment 13 Leonid Natapov 2013-10-17 06:49:36 EDT
fixed. ovirt-hosted-engine-setup-1.0.0-0.5.2.beta1.local.el6.noarch
Comment 14 Charlie 2013-11-27 20:20:30 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 15 Sandro Bonazzola 2013-12-05 06:05:59 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 16 errata-xmlrpc 2014-01-21 11:52:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.