This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1001726 - Engine VM stays down after (second) reboot. Not coming UP.
Engine VM stays down after (second) reboot. Not coming UP.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 11:17 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.4.beta.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:52:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (1.51 MB, text/plain)
2013-08-27 11:17 EDT, Leonid Natapov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18909 None None None Never

  None (edit)
Description Leonid Natapov 2013-08-27 11:17:11 EDT
Created attachment 791066 [details]
vdsm log

Description of problem:

ovirt-hosted-engine setup creates a VM,user chooses boot device for this VM,connects to it using remote-viewer,installs OS on it and VM goes for reboot in order to come up from hard disk. And it comes up successfully.  Till now everything is ok. If,for some reason, user will need  to reboot VM again (after it comes up from HD), VM goes to shut down instead of reboot. It stays in down state.

vdsCLient shows that VM exist but it's DOWN.

vdsm.log attached.
Comment 1 Itamar Heim 2013-08-28 02:18:01 EDT
should this be part of setup or part of ha service?
Comment 2 Oved Ourfali 2013-08-28 02:23:50 EDT
(In reply to Itamar Heim from comment #1)
> should this be part of setup or part of ha service?

In this part the HA service still doesn't kick in, so it should be a part of the setup phase. Personally, I didn't test that, as I didn't need another reboot, but I understand why such a reboot could be required.
Comment 3 Sandro Bonazzola 2013-09-03 03:28:50 EDT
The Hosted Engine VM reboot is converted to destroy by design: it is under the hostedengine VDSM hook control, adding the destroy action to 'on_poweroff', 'on_reboot' and 'on_crash' events.

It has been introduced as workaround for moving from boot from pxe/cdrom to boot from disk and left enabled because we tought that the vm start after a reboot command should be done by the HA service.

At this stage however the HA service is not yet active.

There is a dialog message in engine setup that says:

If you need to reboot the VM you can set a temporary password using the command:

host-deploy --add-console-password=<password>'

We can solve this issue explaining better how to reboot the VM ( adding a note to use hosted-engine --vm-start before --add-console-password )
or disabling the hook after boot from disk and re-enabling it before starting HA daemons. However this will not boot the VM if the user shutdown it instead of rebooting it.
Another solution may be polling the vm status while waiting for the user input (press enter when finished) but this will introduce extra complexity in the setup.

I think that the dialog change should be enough.
Comment 4 Sandro Bonazzola 2013-09-05 12:01:53 EDT
(In reply to Sandro Bonazzola from comment #3)

> I think that the dialog change should be enough.

Dialog updated with upstream patch 18909.

 If you need to reboot the VM you will need to start it manually using the command:
 hosted-engine --vm-start
 You can then set a temporary password using the command:
 hosted-engine --add-console-password=<password>'
Comment 5 Sandro Bonazzola 2013-09-12 05:28:41 EDT
patch merged upstream master.
Comment 7 Leonid Natapov 2013-10-17 06:46:41 EDT
fixed. ovirt-hosted-engine-setup-1.0.0-0.5.2.beta1.local.el6.noarch
Comment 8 Charlie 2013-11-27 20:19:45 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 9 Sandro Bonazzola 2013-12-05 06:03:34 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 10 errata-xmlrpc 2014-01-21 11:52:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.