Bug 1001735 - katello-configure fails
katello-configure fails
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.2
x86_64 Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 11:39 EDT by Duncan Innes
Modified: 2014-09-18 13:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 14:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug (69.45 KB, application/x-gzip)
2013-08-27 11:39 EDT, Duncan Innes
no flags Details
katello-debug (91.50 KB, application/x-gzip)
2013-10-28 10:16 EDT, Duncan Innes
no flags Details
SOSreport from failing system (5.86 MB, application/x-xz)
2013-11-25 15:13 EST, Duncan Innes
no flags Details
latest katello-debug (83.45 KB, application/x-gzip)
2013-11-25 15:15 EST, Duncan Innes
no flags Details

  None (edit)
Description Duncan Innes 2013-08-27 11:39:14 EDT
Created attachment 791085 [details]
katello-debug

Description of problem: katello-configure fails elasticsearch & tomcat6 starts


Version-Release number of selected component (if applicable): 1.3.11-1.el6


How reproducible: Every time


Steps to Reproduce:
1. Install RHEL 6 system from scratch (all yum updates etc)
2. Add Katello and EPEL repos as per https://fedorahosted.org/katello/wiki/Install 
3. yum install -y katello-all
4. katello-configure --user-pass=password

Actual results:  Appears to install well until trying to restart elasticsearch and tomcat6.  The elasticsearch and candlepin manifests (service.pp) both fail and cause further errors during the rest of the installation due to dependencies.


Expected results: Clean install


Additional info: My java -version reports
java version "1.7.0_25"
OpenJDK Runtime Environment (rhel-2.3.10.4.el6_4-x86_64)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

This doesn't quite match what is recommended in the Wiki install page, so I'm not sure if it's relevant.
Comment 1 Duncan Innes 2013-08-28 09:11:44 EDT
Closing this as I didn't get the same errors when reinstalling from nightly.
Comment 2 Duncan Innes 2013-10-28 08:00:21 EDT
Re-opening this bug as it's happening in my clean install of Katello 1.4
Comment 3 Duncan Innes 2013-10-28 10:11:50 EDT
Details haven't changed from above except for installing katello-1.4.12-1.el6.noarch now.  Still a clean RHEL 6.4 system.

Errors in log are:

[root@edpldwkst03 ~]# grep -i error /var/log/katello/katello-configure/main.log 
131028-14:03:07 Error: Could not start Service[elasticsearch]: Execution of '/usr/sbin/service-wait elasticsearch start' returned 5: 
131028-14:03:07 Error: /Stage[main]/Elasticsearch::Service/Service[elasticsearch]/ensure: change from stopped to running failed: Could not start Service[elasticsearch]: Execution of '/usr/sbin/service-wait elasticsearch start' returned 5: 
131028-14:03:07 Error: /Stage[main]/Elasticsearch::Service/Service[elasticsearch]: Failed to call refresh: Could not restart Service[elasticsearch]: Execution of '/usr/sbin/service-wait elasticsearch restart' returned 5: 
131028-14:03:07 Error: /Stage[main]/Elasticsearch::Service/Service[elasticsearch]: Could not restart Service[elasticsearch]: Execution of '/usr/sbin/service-wait elasticsearch restart' returned 5: 
131028-14:04:20 Error: Could not start Service[tomcat6]: Execution of '/usr/sbin/service-wait tomcat6 start' returned 5: 
131028-14:04:20 Error: /Stage[main]/Candlepin::Service/Service[tomcat6]/ensure: change from stopped to running failed: Could not start Service[tomcat6]: Execution of '/usr/sbin/service-wait tomcat6 start' returned 5: 
131028-14:04:22 Error: /Stage[main]/Candlepin::Service/Service[tomcat6]: Failed to call refresh: Could not restart Service[tomcat6]: Execution of '/usr/sbin/service-wait tomcat6 restart' returned 5: 
131028-14:04:22 Error: /Stage[main]/Candlepin::Service/Service[tomcat6]: Could not restart Service[tomcat6]: Execution of '/usr/sbin/service-wait tomcat6 restart' returned 5: 
131028-14:05:34 Error: Could not start Service[foreman]: Execution of '/usr/sbin/service-wait foreman start' returned 5: 
131028-14:05:34 Error: /Stage[main]/Foreman::Service/Service[foreman]/ensure: change from stopped to running failed: Could not start Service[foreman]: Execution of '/usr/sbin/service-wait foreman start' returned 5: 
131028-14:05:43 Error: /Stage[main]/Foreman::Service/Service[foreman]: Failed to call refresh: Could not restart Service[foreman]: Execution of '/usr/sbin/service-wait foreman restart' returned 5: 
131028-14:05:43 Error: /Stage[main]/Foreman::Service/Service[foreman]: Could not restart Service[foreman]: Execution of '/usr/sbin/service-wait foreman restart' returned 5: 

katello-debug to follow.
Comment 4 Duncan Innes 2013-10-28 10:16:48 EDT
Created attachment 816816 [details]
katello-debug
Comment 5 Mike McCune 2013-11-25 13:49:06 EST
moving to the Satellite 6 product to track with the MDP process.
Comment 6 RHEL Product and Program Management 2013-11-25 14:22:42 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 8 Duncan Innes 2013-11-25 14:40:12 EST
Performing a failed install at the moment.  Will post new katello-debug shortly along with sosreport in case it's helpful.

Not sure how relevant it is that I closed this case initially because the nightly katello repos didn't have this issue.  Back on 28 Aug at least.
Comment 9 Duncan Innes 2013-11-25 15:13:33 EST
Created attachment 828857 [details]
SOSreport from failing system
Comment 10 Duncan Innes 2013-11-25 15:15:35 EST
Created attachment 828870 [details]
latest katello-debug

There are 12 "Error" lines in main.log.  4 each for elasticsearch, tomcat6 & foreman service start failures.
Comment 13 Bryan Kearney 2014-06-03 14:02:32 EDT
We are testing nightlies on RHEL 6.5 and the install is working fine. I believe that this bug is fixed. If you feel differently, please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.