Bug 1001764 - RFE: Add support for virtio-rng device
RFE: Add support for virtio-rng device
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 13:10 EDT by Amit Shah
Modified: 2013-09-25 09:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 09:35:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2013-08-27 13:10:34 EDT
Description of problem:

QEMU 1.3 onwards supports the virtio-rng device that can enhance the entropy available to guests via the virtio hwrng driver in Linux guests.  libvirt supports this since 1.0.3.

More information at

https://fedoraproject.org/wiki/Features/Virtio_RNG
http://wiki.qemu-project.org/Features/VirtIORNG

Invocation details at

https://fedoraproject.org/wiki/QA:Testcase_Virtualization_VirtioRNG

Note You need to log in before you can comment on or make changes to this bug.