Bug 1001817 - sos version => sos-1.7-9.27.el5 should be added to the spec file.
sos version => sos-1.7-9.27.el5 should be added to the spec file.
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (distribution) (Show other bugs)
1.5.10
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Red Hat Kernel QE team
:
Depends On:
Blocks: 1001813
  Show dependency treegraph
 
Reported: 2013-08-27 16:16 EDT by Rob Landry
Modified: 2013-10-08 19:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 19:53:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Landry 2013-08-27 16:16:42 EDT
Description of problem:

Older versions of sos do not include the batch option.  Adding this dependency to the test suite will bring up this issue on 5.0,5.1, and 5.2 certification at the start instead of during testing.  Such that the sos errata can be installed.


Additional info:

The exception of installing the sos errata is already approved for 5.0, 5.1, and 5.2 certifications.  Details are discussed in BZ#997680.
Comment 4 Greg Nichols 2013-09-11 09:39:33 EDT
Some additional notes on the problem, and solution.

Older versions of sos do not support the --batch option, which hwcert-client needs to gather hardware information in the info test.  

The solution is for the hwcert-client package to require newer versions of sos (sos-1.7-9.27.el5 and later) which provide the --batch option.  That way, when users install hwcert-client it will indicate that the later versions must be installed.
Comment 6 errata-xmlrpc 2013-10-08 19:53:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1413.html

Note You need to log in before you can comment on or make changes to this bug.