Bug 1001827 - Unable to delete Data Provider
Unable to delete Data Provider
Status: CLOSED WONTFIX
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Dashboard Builder (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 16:48 EDT by Van Halbert
Modified: 2015-03-11 11:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The user is not allowed to delete a Data Provider in JBoss Dashboard Builder if it is used by KPIs. Currently, it is difficult for the user to determine which KPIs are using it.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-28 14:21:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPM-4108 Major Closed Unable to delete Data Provider because it is used by 2 KPI's, but no way to find the 2 KPI's 2015-03-11 11:28:31 EDT

  None (edit)
Comment 3 JBoss JIRA Server 2013-11-18 07:04:44 EST
David Gutierrez <dgutierr@redhat.com> made a comment on jira JBPM-4108

To cope with this scenario an option could be to delete the data provider but let the user decide between two options:

1.- Force to delete also the related KPIs.
2.- Display what are the affected KPIs and where are located at.

The data provider management UI should be modified to add this selector to the delete icon.
Comment 6 Van Halbert 2014-10-28 14:21:28 EDT
Rejecting this BZ as it won't be fixed and because dashboard builder is being re-developed.
Comment 7 JBoss JIRA Server 2015-03-11 11:28:21 EDT
Roger Martínez <roger600@gmail.com> updated the status of jira JBPM-4108 to Resolved
Comment 8 JBoss JIRA Server 2015-03-11 11:28:31 EDT
Roger Martínez <roger600@gmail.com> updated the status of jira JBPM-4108 to Closed

Note You need to log in before you can comment on or make changes to this bug.