Bug 1001847 - [RFE] add ALT + PrintScreen to Remote Viewer "Send key" menu
[RFE] add ALT + PrintScreen to Remote Viewer "Send key" menu
Status: CLOSED DUPLICATE of bug 873341
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Marc-Andre Lureau
Desktop QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-27 20:33 EDT by Bryan Yount
Modified: 2014-04-02 22:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-01 08:10:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 466653 None None None Never

  None (edit)
Description Bryan Yount 2013-08-27 20:33:19 EDT
3. What is the nature and description of the request?
The customer would like the ability to capture screenshots of the active window inside their guests. The way to do this on a normal Windows system is to hold down the ALT key while pressing PrintScreen. There appears to be no way to do this with virt-viewer currently.


4. Why does the customer need this? (List the business requirements here)
It is often convenient to use ALT+Print Screen to capture just the active window to the clipboard instead of having to edit the image later. This would save time when taking many screenshots for use in internal training material.


5. How would the customer like to achieve this? (List the functional requirements here)
An additional item in the "Send key" menu that is "ALT + PrintScreen"


7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
No


8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
RHEV 3.4

10. List any affected packages or components.
virt-viewer
mingw-virt-viewer


11. Would the customer be able to assist in testing this functionality if implemented?
Yes
Comment 2 Christophe Fergeau 2013-08-28 05:47:10 EDT
I'd tend to change that bug to 'alt+printscreen is not correctly passed to the VM', with the preferred resolution being that pressing alt+printscreen when the client is focused takes a screenshot of a window in the guest OS. If this is not possible/desirable for some reason, then adding alt+printscreen to the 'send key' menu is an acceptable fix for your customer. Does this sound right?
Comment 3 Marc-Andre Lureau 2013-08-28 06:43:28 EDT
(In reply to Christophe Fergeau from comment #2)
> I'd tend to change that bug to 'alt+printscreen is not correctly passed to
> the VM', with the preferred resolution being that pressing alt+printscreen
> when the client is focused takes a screenshot of a window in the guest OS.
> If this is not possible/desirable for some reason, then adding
> alt+printscreen to the 'send key' menu is an acceptable fix for your
> customer. Does this sound right?

I think it should be 2 bugs, because adding a menu item is trivial, which tweaking various WM or OS settings is a lot more trickier and problematic...
Comment 6 Marc-Andre Lureau 2014-03-31 13:06:26 EDT
well, alt+printscrn works for me, 

I am testing with f20 client -> winxp guest/client -> rhel6 guest.

Please provide more details how to reproduce.
Comment 8 Christophe Fergeau 2014-04-01 08:05:31 EDT
This is broken for me with the 3.2 Windows client (alt+printscreen takes a screenshot of the client window, not of the currently focused guest window). This works for me with the 3.3 Windows client (alt+printscreen takes a screenshot of the currently focused guest window). Duplicate of bug #986027 ?
Comment 9 Marc-Andre Lureau 2014-04-01 08:10:37 EDT
(In reply to Christophe Fergeau from comment #8)
> This is broken for me with the 3.2 Windows client (alt+printscreen takes a
> screenshot of the client window, not of the currently focused guest window).
> This works for me with the 3.3 Windows client (alt+printscreen takes a
> screenshot of the currently focused guest window). Duplicate of bug #986027 ?

yes, of #873341

so closing as such

*** This bug has been marked as a duplicate of bug 873341 ***

Note You need to log in before you can comment on or make changes to this bug.