Bug 1001929 - SELinux is preventing /usr/sbin/httpd from 'write' accesses on the directory /home/kwkhoo/Projects/rvs/public_html/tmp.
SELinux is preventing /usr/sbin/httpd from 'write' accesses on the directory ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:28a47c72565ccf305d52c9d66a8...
:
: 1001930 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 03:19 EDT by kwkhoo88
Modified: 2013-08-28 15:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 15:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kwkhoo88 2013-08-28 03:19:43 EDT
Description of problem:
SELinux is preventing /usr/sbin/httpd from 'write' accesses on the directory /home/kwkhoo/Projects/rvs/public_html/tmp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that httpd should be allowed write access on the tmp directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /home/kwkhoo/Projects/rvs/public_html/tmp [ dir ]
Source                        httpd
Source Path                   /usr/sbin/httpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           httpd-2.4.6-2.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-71.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.9-200.fc19.x86_64 #1 SMP Wed
                              Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-28 15:16:22 SGT
Last Seen                     2013-08-28 15:16:22 SGT
Local ID                      791ad23f-8929-4832-982e-e2e662cf0466

Raw Audit Messages
type=AVC msg=audit(1377674182.17:459): avc:  denied  { write } for  pid=2445 comm="httpd" name="tmp" dev="dm-2" ino=9440935 scontext=system_u:system_r:httpd_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir


type=SYSCALL msg=audit(1377674182.17:459): arch=x86_64 syscall=unlink success=no exit=EACCES a0=7f220a5d9ae0 a1=1 a2=0 a3=7f21fbfda3a0 items=0 ppid=597 pid=2445 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 ses=4294967295 tty=(none) comm=httpd exe=/usr/sbin/httpd subj=system_u:system_r:httpd_t:s0 key=(null)

Hash: httpd,httpd_t,user_home_t,dir,write

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.9-200.fc19.x86_64
type:           libreport

Potential duplicate: bug 669199
Comment 1 Daniel Walsh 2013-08-28 15:01:52 EDT
# semanage fcontext -a -t httpd_user_content_rw_t '/home/kwkhoo/Projects/rvs/public_html(/.*)?' 

# restorecon -R -v /home/kwkhoo/Projects/rvs
Comment 2 Daniel Walsh 2013-08-28 15:03:09 EDT
*** Bug 1001930 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.