Bug 1001930 - SELinux is preventing /usr/bin/bash from 'execute' accesses on the file /home/kwkhoo/Projects/rvs/public_html/components/rvs/backend/system/hierarchy.
SELinux is preventing /usr/bin/bash from 'execute' accesses on the file /home...
Status: CLOSED DUPLICATE of bug 1001929
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b47deb3e798c5cd4a4d6364f125...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 03:20 EDT by kwkhoo88
Modified: 2013-08-28 15:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 15:03:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kwkhoo88 2013-08-28 03:20:26 EDT
Description of problem:
SELinux is preventing /usr/bin/bash from 'execute' accesses on the file /home/kwkhoo/Projects/rvs/public_html/components/rvs/backend/system/hierarchy.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that bash should be allowed execute access on the hierarchy file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep sh /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                system_u:object_r:user_home_t:s0
Target Objects                /home/kwkhoo/Projects/rvs/public_html/components/r
                              vs/backend/system/hierarchy [ file ]
Source                        sh
Source Path                   /usr/bin/bash
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bash-4.2.45-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-71.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.9-200.fc19.x86_64 #1 SMP Wed
                              Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-08-28 15:16:22 SGT
Last Seen                     2013-08-28 15:16:22 SGT
Local ID                      a59a659d-7291-4385-bd44-0a2bbcfde0ad

Raw Audit Messages
type=AVC msg=audit(1377674182.105:461): avc:  denied  { execute } for  pid=2460 comm="sh" name="hierarchy" dev="dm-2" ino=9306904 scontext=system_u:system_r:httpd_t:s0 tcontext=system_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1377674182.105:461): arch=x86_64 syscall=access success=no exit=EACCES a0=1abd590 a1=1 a2=7fff682214e0 a3=0 items=0 ppid=1 pid=2460 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 ses=4294967295 tty=(none) comm=sh exe=/usr/bin/bash subj=system_u:system_r:httpd_t:s0 key=(null)

Hash: sh,httpd_t,user_home_t,file,execute

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.9-200.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-08-28 15:03:09 EDT

*** This bug has been marked as a duplicate of bug 1001929 ***

Note You need to log in before you can comment on or make changes to this bug.