Bug 1002003 - BPMN validation errors after starting DTGov workflow
BPMN validation errors after starting DTGov workflow
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Kurt T Stam
Stefan Bunciak
: Reopened
: 1008461 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 05:58 EDT by Stefan Bunciak
Modified: 2014-03-05 10:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 09:24:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker DTGOV-74 Major Closed BPMN validation errors after starting DTGov workflow 2014-03-05 10:53:24 EST

  None (edit)
Description Stefan Bunciak 2013-08-28 05:58:53 EDT
Description of problem:

BPMN validation errors present in server log, process instance is successfully started.

Version-Release number of selected component (if applicable):
* S-RAMP 6.0.0.ER1
* Community seed data (since productized are not available yet)

How reproducible:
* First time when the process instance is started

Steps to Reproduce:
1. Create new deployment in DTGov
2. Wait for the workflow (SimpleReleaseProcess) to start

Actual results:
* http://pastebin.test.redhat.com/160790

Expected results:
* No validation errors OOTB

Additional info:
Comment 2 Kurt T Stam 2013-09-05 14:27:22 EDT
These errors are harmless and have to do with an old datastructure for BPMN simulation. I will remove this data.
Comment 3 Kurt T Stam 2013-10-02 21:00:58 EDT
*** Bug 1008461 has been marked as a duplicate of this bug. ***
Comment 7 Kurt T Stam 2013-10-08 09:24:30 EDT
the symptoms of 1016474 are a bit more severe then this one; but it's essentially the same issue. I finally have a working Eclipse BPMN editor now so am working on this. Marking as duplicate of 1016474.

*** This bug has been marked as a duplicate of bug 1016474 ***
Comment 8 Kurt T Stam 2013-10-08 10:31:36 EDT
Turns out not to a dup of bug 1016474
Comment 9 JBoss JIRA Server 2013-10-11 11:10:35 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-74 to Resolved
Comment 10 JBoss JIRA Server 2013-10-11 11:10:42 EDT
Kurt Stam <kurt.stam@jboss.com> updated the status of jira DTGOV-74 to Closed
Comment 11 Stefan Bunciak 2013-12-12 09:15:44 EST
Verified in FSW 6.0.0.ER7
Comment 12 JBoss JIRA Server 2014-03-05 10:40:50 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-74 to Reopened
Comment 13 JBoss JIRA Server 2014-03-05 10:45:57 EST
Eric Wittmann <eric.wittmann@redhat.com> updated the status of jira DTGOV-74 to Closed

Note You need to log in before you can comment on or make changes to this bug.