This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1002094 - virt-manager insists on openssh-askpass being installed
virt-manager insists on openssh-askpass being installed
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 09:14 EDT by Gerd Hoffmann
Modified: 2015-11-04 20:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 20:03:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2013-08-28 09:14:01 EDT
Description of problem:
$subject

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Try connect to qemu+ssh://root@${hostname}/system
2. virt-manager suggests to install openssh-askpass
3. Hit 'no'.

Actual results:
virt-manager fails to connect

Expected results:
virt-manager succeeds to connect

Additional info:
this is a standard gnome3 install, with ssh-agent running and holding the keys needed to connect.  gnome asks for the passphrase when needed, which works just fine without openssh-askpass ...
Comment 2 Martin Kletzander 2013-08-28 11:18:14 EDT
If I'm not mistaken, the package in virt-manager is used for talking to the ssh not just because of the password request.  In case the remote is not in known hosts, I guess.  I'll see how we can make it easier for users.
Comment 5 Giuseppe Scrivano 2014-07-29 07:10:45 EDT
not sure how this could be fixed without installing openssh-askpass (https://bugzilla.redhat.com/show_bug.cgi?id=754484).  Probably we could try to connect first and in case it fails we can repeat the operation asking the user to install openssh-askpass first.  What do you think?
Comment 9 Cole Robinson 2015-11-04 20:03:54 EST
We only ask 'do you want to install askpass' if ssh auth throws an error, and the error message mentions missing askpass binary, meaning ssh tried to launch it. We don't pre-emptively check for askpass or anything... So if ssh keys are properly setup, I don't think there should be any problem.

So closing as WORKSFORME, but if I'm wrong please reopen and provide full virt-manager --debug output when reproducing

Note You need to log in before you can comment on or make changes to this bug.