This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1002340 - Using OpenID login fails to inform user the username is already in use
Using OpenID login fails to inform user the username is already in use
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.0
Assigned To: Patrick Huang
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-28 19:45 EDT by Damian Jansen
Modified: 2013-11-26 22:35 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.0.3-SNAPSHOT (20130913-0020)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-08-28 19:45:17 EDT
Description of problem:
If a user logs in with OpenID for the first time, the Edit Profile page fails to inform the user that the username is taken if so. Secondly, on pressing the button, the username field disappears so the user cannot remedy the problem.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Easy always

Steps to Reproduce:
Pre: An OpenID server to log into
1. Press Login
2. Select OpenID (I used Google)
3. Enter a name
4. Enter a username that is already taken
5. Enter an email and press Save

Actual results:
Two fields are now showing - name and email - and the only indication that the username is not available is the server log.

Expected results:
Username already taken errors should be inline, ala internal auth signup.

Additional info:
Couldn't think of another way to add more "use" words to the summary.
Comment 1 Sean Flanigan 2013-08-28 20:04:52 EDT
(In reply to Damian Jansen from comment #0)
> Description of problem:
> If a user logs in with OpenID for the first time, the Edit Profile page
> fails to inform the user that the username is taken if so. Secondly, on
> pressing the button, the username field disappears so the user cannot remedy
> the problem.

> Additional info:
> Couldn't think of another way to add more "use" words to the summary.

"If a user uses OpenID to log in for the first time, the Edit Profile page fails to inform the user if the username is already used. Secondly, on using the Save button, the username field disappears so the user cannot remedy the problem and the page becomes unusable." -Fixed!

If there's no useful feedback to the user at all, I think we should target this for 3.0.x.
Comment 2 Patrick Huang 2013-09-09 01:04:57 EDT
https://github.com/zanata/zanata-server/pull/164
Comment 3 Patrick Huang 2013-09-09 01:12:56 EDT
cherry picked to release branch
https://github.com/zanata/zanata-server/commit/57f8743af6544eef197473f3efaf4826f0a35a07
Comment 4 Damian Jansen 2013-09-09 02:33:45 EDT
Seems to be a problem with the stability of the username field, in that sometimes it does not show the message, even after pressing Save (race condition with the "should show" function?)
Comment 5 Patrick Huang 2013-09-11 23:28:35 EDT
fixed in https://github.com/zanata/zanata-server/pull/175
Comment 6 Ding-Yi Chen 2013-09-16 21:27:30 EDT
VERIFIED with Zanata version 3.0.3-SNAPSHOT (20130913-0020)

and Zanata version 3.1-SNAPSHOT (20130913-1232)
Comment 7 Sean Flanigan 2013-11-26 22:13:37 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 8 Sean Flanigan 2013-11-26 22:15:35 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 9 Sean Flanigan 2013-11-26 22:19:01 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 10 Sean Flanigan 2013-11-26 22:23:29 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 11 Sean Flanigan 2013-11-26 22:33:41 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 12 Sean Flanigan 2013-11-26 22:35:57 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.