Bug 1002426 - Password input for both the root password and when creating a user in anaconda is *very* slow
Password input for both the root password and when creating a user in anacond...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cracklib (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 03:47 EDT by Mike FABIAN
Modified: 2013-09-02 10:23 EDT (History)
13 users (show)

See Also:
Fixed In Version: cracklib-2.9.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 10:02:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
password-input-extremely-slow.ogv (4.45 MB, video/ogg)
2013-08-29 03:47 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-08-29 03:47:39 EDT
Created attachment 791629 [details]
password-input-extremely-slow.ogv

Fedora 20 Alpha TC2 netinstall in qemu:

    ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 4 -drive file=./Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2-output.log -name Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-20-Alpha-TC2/Fedora-20-Alpha-TC2-x86_64-netinst.iso -boot c -spice port=6000,disable-ticketing -vga cirrus -display vnc=:4 -net nic -net user,hostname=Fedora-20-Alpha-TC2-x86_64-netinst.iso.qcow2,hostfwd=tcp::5556-:22 -monitor stdio -usb

I selected “Japanese” on the first screen, accepted all other defaults
and started the installation.

While the installation was running, I used two buttons above the progress
bar to enter a root password and to create a user.

Both for entering the root password and the user password, typing is 
*extremely* slow.

When I create the user, I can type fast in the fields for the full
user name and the account name.

But typing some stuff into the password field is very slow.

It is especially easy to notice when typing a long password fast,
deleting it, and typing it again.

See the attached video.

The long pauses in the video, where nothing seems to happen,
are when I am waiting that the keys I have already typed 
occur in the password entry field.

You can see that when I deleted everything in the top one of the 2 password
fields again and type 

   testing

it stops at

   ••••i

and after a *very* long pause, the “ng” characters finally appear as well.

After that I quickly try to type some more characters, again they
appear only after a long wait.
Comment 1 David Shea 2013-08-29 09:59:32 EDT
The delay is due to the cracklib package changing to compressed dictionaries  and libpwquality decompressing it on each check() call.

Note You need to log in before you can comment on or make changes to this bug.