Bug 1002440 - [abrt] hplip-3.13.7-1.fc19: models.py:425:read_section:TypeError: coercing to Unicode: need string or buffer, NoneType found
[abrt] hplip-3.13.7-1.fc19: models.py:425:read_section:TypeError: coercing to...
Status: CLOSED DUPLICATE of bug 957329
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:238c11544fb6b466e5a8bf71119...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 04:20 EDT by alexander.naumann
Modified: 2013-08-29 10:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 09:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2013-08-29 04:20 EDT, alexander.naumann
no flags Details
File: environ (1.35 KB, text/plain)
2013-08-29 04:20 EDT, alexander.naumann
no flags Details

  None (edit)
Description alexander.naumann 2013-08-29 04:20:20 EDT
Version-Release number of selected component:
hplip-3.13.7-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/hp-makeuri -c technik
executable:     /usr/bin/hp-makeuri
kernel:         3.10.9-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
models.py:425:read_section:TypeError: coercing to Unicode: need string or buffer, NoneType found

Traceback (most recent call last):
  File "/usr/bin/hp-makeuri", line 123, in <module>
    cups_uri, sane_uri, fax_uri = device.makeURI(param, jd_port)
  File "/usr/share/hplip/base/device.py", line 409, in makeURI
    mq = queryModelByURI(cups_uri)
  File "/usr/share/hplip/base/device.py", line 450, in queryModelByURI
    return queryModelByModel(model)
  File "/usr/share/hplip/base/device.py", line 439, in queryModelByModel
    return model_dat[model]
  File "/usr/share/hplip/base/models.py", line 515, in __getitem__
    if self.read_section(self.released_dat, model):
  File "/usr/share/hplip/base/models.py", line 425, in read_section
    fd = file(filename)
TypeError: coercing to Unicode: need string or buffer, NoneType found

Local variables in innermost frame:
in_section: False
is_include: False
section: 'hp_laserjet_professional_p1606dn'
cache: {}
filename: None
found: False
self: <base.models.ModelData instance at 0xfc36c8>
Comment 1 alexander.naumann 2013-08-29 04:20:25 EDT
Created attachment 791642 [details]
File: backtrace
Comment 2 alexander.naumann 2013-08-29 04:20:28 EDT
Created attachment 791643 [details]
File: environ
Comment 3 Jaromír Končický 2013-08-29 09:14:02 EDT

*** This bug has been marked as a duplicate of bug 957329 ***
Comment 4 Jaromír Končický 2013-08-29 09:33:27 EDT
The problem is most probably that the script can't read file '/usr/share/hplip/data/models/models.dat'. This file shall be a part of 'hplip-common' package.
Please tell if you have this file and what 'rpm -qf /usr/share/hplip/data/models/models.dat' outputs.
Can you reproduce this bug and how? What you do or which command you use?
Comment 5 alexander.naumann 2013-08-29 10:06:14 EDT
The file '/usr/share/hplip/data/models/models.dat' did not existed but:

# rpm -qf /usr/share/hplip/data/models/models.dat
hplip-common-3.13.7-1.fc19.x86_64

I removed hplip-common.x86_64 with yum and get the error that the file could not be removed - they does not exist.

Then i reinstall hplip-common and now everything works fine.
I have no idea why it was not from the beginning there.
Comment 6 Jaromír Končický 2013-08-29 10:25:52 EDT
Thanks for reply, nice to see it works well for you now.

Note You need to log in before you can comment on or make changes to this bug.