Bug 1002465 - katello does not start after clean install on fedora18
katello does not start after clean install on fedora18
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity unspecified (vote)
: Unspecified
: 6.0
Assigned To: Partha Aji
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 05:25 EDT by rob.verduijn
Modified: 2014-12-04 14:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-04 14:08:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from /usr/share/katello/script/katello-debug (72.55 KB, application/x-gzip)
2013-08-29 05:25 EDT, rob.verduijn
no flags Details
katello does not start after clean install on CentOS release 6.4 (96.75 KB, application/gzip)
2013-11-26 08:46 EST, Vishal Sinha
no flags Details

  None (edit)
Description rob.verduijn 2013-08-29 05:25:00 EDT
Created attachment 791655 [details]
output from  /usr/share/katello/script/katello-debug

Description of problem:
after doing a clean install of katello on fedora18, katello fails to start.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install fedora18 with @base and @core package groups and chrony package
2. update fedora18
3. disable and shutdown firewalld 
4. disable and shutdown networkmanager
5. configure network with static ip and dns settings
6. enable network
7. reboot
8. add katello repo 
rpm -Uvh http://fedorapeople.org/groups/katello/releases/yum/1.3/Fedora/18/x86_64/katello-repos-1.3.5-1.fc18.noarch.rpm
9. install katello
yum install -y katello-all
10 configure katello
katello-configure --user-pass=admin
11 run katello
service katello start

Actual results:
katello fails to start

Expected results:
katello starts

Additional info:
attached error logs
Comment 1 Tom McKay 2013-08-29 09:12:59 EDT
Relevant snippet from db_migrate.log


An error has occurred, this and all later migrations canceled:

can't convert nil into String
/usr/share/gems/gems/netrc-0.7.1/lib/netrc.rb:9:in `join'
/usr/share/gems/gems/netrc-0.7.1/lib/netrc.rb:9:in `default_path'
/usr/share/gems/gems/netrc-0.7.1/lib/netrc.rb:15:in `read'
/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:121:in `parse_url_with_auth'
/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
/usr/share/gems/gems/rest-client-1.6.7/lib/restclient/request.rb:34:in `execute'
/usr/share/gems/gems/rest-client-1.6.7/lib/restclient.rb:88:in `head'
/usr/share/gems/gems/tire-0.3.13.pre/lib/tire/http/client.rb:43:in `head'
/usr/share/gems/gems/tire-0.3.13.pre/lib/tire/index.rb:12:in `exists?'
/usr/share/gems/gems/tire-0.3.13.pre/lib/tire/model/indexing.rb:99:in `create_elasticsearch_index'
/usr/share/gems/gems/tire-0.3.13.pre/lib/tire/model/indexing.rb:53:in `mapping'
/usr/share/gems/gems/tire-0.3.13.pre/lib/tire/model/search.rb:280:in `mapping'
/usr/share/katello/app/models/glue/elastic_search/repository.rb:22:in `block in included'
/usr/share/katello/app/models/glue/elastic_search/repository.rb:18:in `class_eval'
/usr/share/katello/app/models/glue/elastic_search/repository.rb:18:in `included'
/usr/share/katello/app/models/repository.rb:17:in `include'
/usr/share/katello/app/models/repository.rb:17:in `<class:Repository>'
/usr/share/katello/app/models/repository.rb:13:in `<top (required)>'
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `block in require'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:359:in `require_or_load'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:502:in `load_missing_constant'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:192:in `block in const_missing'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `each'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `const_missing'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:514:in `load_missing_constant'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:192:in `block in const_missing'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `each'
/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:190:in `const_missing'
/usr/share/katello/db/migrate/20120702175532_add_repository_library_id.rb:7:in `up'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:370:in `up'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:410:in `block (2 levels) in migrate'
/usr/share/ruby/benchmark.rb:280:in `measure'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:410:in `block in migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/connection_pool.rb:123:in `with_connection'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:389:in `migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:528:in `migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:720:in `block (2 levels) in migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:775:in `call'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:775:in `block in ddl_transaction'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:192:in `transaction'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:208:in `transaction'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:775:in `ddl_transaction'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:719:in `block in migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:700:in `each'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:700:in `migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:570:in `up'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/migration.rb:551:in `migrate'
/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/railties/databases.rake:153:in `block (2 levels) in <top (required)>'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:228:in `call'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:228:in `block in execute'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:223:in `each'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:223:in `execute'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:166:in `block in invoke_with_call_chain'
/usr/share/ruby/monitor.rb:211:in `mon_synchronize'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:159:in `invoke_with_call_chain'
/usr/share/gems/gems/rake-0.9.6/lib/rake/task.rb:152:in `invoke'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:143:in `invoke_task'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:101:in `block (2 levels) in top_level'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:101:in `each'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:101:in `block in top_level'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:110:in `run_with_threads'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:95:in `top_level'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:73:in `block in run'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:160:in `standard_exception_handling'
/usr/share/gems/gems/rake-0.9.6/lib/rake/application.rb:70:in `run'
/usr/share/gems/gems/rake-0.9.6/bin/rake:37:in `<top (required)>'
/usr/bin/rake:23:in `load'
/usr/bin/rake:23:in `<main>'
Tasks: TOP => db:migrate
Comment 2 Vishal Sinha 2013-11-26 08:46:47 EST
Created attachment 829275 [details]
katello does not start after clean install on CentOS release 6.4

After doing a clean install of katello on CentOS release 6.4, katello fails to start. I have attached the log files for same.
Comment 3 Bryan Kearney 2014-01-21 14:07:32 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 4 RHEL Product and Program Management 2014-01-21 14:19:26 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 7 Bryan Kearney 2014-12-04 14:08:41 EST
We will not be addressing Fedora 18 installs. You can see the current community installs at http://www.katello.org/docs/installation/index.html

Note You need to log in before you can comment on or make changes to this bug.