This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1002613 - brick logs continuously reporting " I [socket.c:2237:socket_event_handler] 0-transport: disconnecting now"
brick logs continuously reporting " I [socket.c:2237:socket_event_handler] 0-...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: krishnan parthasarathi
spandura
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 10:38 EDT by spandura
Modified: 2015-11-03 18:05 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Previously, the bricks tried to connect to the quota daemon even when quota was disabled. This resulted in connection failure messages in the brick logs. Now, with this update, bricks do not connect to the quota daemon when quota is disabled.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:35:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandura 2013-08-29 10:38:55 EDT
Description of problem:
==========================
After an upgrade from "glusterfs 3.4.0.24rhs built on Aug 27 2013 08:08:42" to "glusterfs 3.4.0.27rhs built on Aug 29 2013 09:57:33" restarted a volume. In the brick logs following message is continuously reported. 

[2013-08-29 14:33:27.532882] I [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 14:33:30.533262] I [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 14:33:33.533875] I [socket.c:2237:socket_event_handler] 0-transport: disconnecting now

Version-Release number of selected component (if applicable):
============================================================
Upgrade from "glusterfs 3.4.0.24rhs built on Aug 27 2013 08:08:42" to "glusterfs 3.4.0.27rhs built on Aug 29 2013 09:57:33"

How reproducible:


Steps to Reproduce:
=====================
1. Install "glusterfs 3.4.0.24rhs built on Aug 27 2013 08:08:42" on 2 storage nodes. 

2. Create a volume. 

3. Start the volume.

4. Stop the volume

5. Stop glusterd on both the storage nodes. 

6. Upgrade to "glusterfs 3.4.0.27rhs built on Aug 29 2013 09:57:33".

7. Start glusterd on both the storage nodes. 

8. Start the volume.
Comment 1 Gowrishankar Rajaiyan 2013-08-29 10:44:30 EDT
Seeing this in glusterfs-server-3.4.0.20rhs-2.el6rhs.x86_64 as well.

[root@localhost ~]# grep "socket.c:2237:socket_event_handler" /var/log/glusterfs/bricks/rhs-bricks-cinder.log 
[2013-08-29 09:55:22.278968] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 09:55:22.307889] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 09:55:22.348930] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 09:55:22.416894] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 11:21:33.130381] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 11:21:33.302732] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 11:22:22.539190] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 11:22:22.842289] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 14:16:00.059407] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 14:16:04.551096] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
[2013-08-29 14:16:04.619495] D [socket.c:2237:socket_event_handler] 0-transport: disconnecting now
Comment 3 Amar Tumballi 2013-08-30 02:32:18 EDT
https://code.engineering.redhat.com/gerrit/#/c/12255
Comment 4 Amar Tumballi 2013-08-30 05:44:27 EDT
https://code.engineering.redhat.com/gerrit/#/c/12267
Comment 5 spandura 2013-09-10 07:45:55 EDT
Verified the fix on the build:-
==============================
upgrade from glusterfs-3.4.0.32 to glusterfs 3.4.0.33rhs built on Sep  8 2013 13:20:26.

Bug is fixed. Moving it to verified state.
Comment 6 Scott Haines 2013-09-23 18:25:07 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 7 Amar Tumballi 2013-10-08 04:10:09 EDT
https://code.engineering.redhat.com/gerrit/13527 is posted as part of the better fix for quota behavior.
Comment 8 spandura 2013-10-28 02:52:29 EDT
Verified the fix with the steps mentioned in Description from build"glusterfs 3.4.0.35rhs built on Oct 15 2013 14:06:04" to build "glusterfs 3.4.0.36rhs built on Oct 22 2013 10:56:18"

Bug is fixed. Moving this bug to verified state.
Comment 9 errata-xmlrpc 2013-11-27 10:35:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.