Bug 1002625 - cyrus-sasl-gssapi does not work on s390x
cyrus-sasl-gssapi does not work on s390x
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cyrus-sasl (Show other bugs)
7.0
s390x Unspecified
urgent Severity urgent
: beta
: 7.0
Assigned To: Petr Lautrbach
David Spurek
: TestBlocker
: 1005267 (view as bug list)
Depends On:
Blocks: 917637
  Show dependency treegraph
 
Reported: 2013-08-29 11:25 EDT by David Spurek
Modified: 2015-03-02 00:28 EST (History)
8 users (show)

See Also:
Fixed In Version: cyrus-sasl-2.1.26-12.1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:19:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2013-08-29 11:25:46 EDT
Description of problem:
cyrus-sasl-gssapi does not work on s390x. I have kerberos and ldap server. The I try run ldapsearch -Y GSSAPI, but it fails with:

ldap_sasl_interactive_bind_s: Unknown authentication method (-6)
	additional info: SASL(-4): no mechanism available: No worthy mechs found

In /var/log/messages the I can see:
Aug 29 15:19:01 ibm-z10-32 ldapsearch: unable to dlopen /usr/lib64/sasl2/libgssapiv2.so: /usr/lib64/sasl2/libgssapiv2.so: undefined symbol: gsskrb5_register_acceptor_identity
Aug 29 15:19:01 ibm-z10-32 ldapsearch: No worthy mechs found


Version-Release number of selected component (if applicable):
cyrus-sasl-2.1.26-9.el7

How reproducible:
always

Steps to Reproduce:
1.setup kerberos and ldap server
2.kinit
3.ldapsearch -Y GSSAPI

Actual results:
ldapsearch fail

Expected results:
ldapsearch pass

Additional info:
Comment 3 Jan Synacek 2013-09-10 08:13:38 EDT
*** Bug 1005267 has been marked as a duplicate of this bug. ***
Comment 4 Petr Lautrbach 2013-09-10 09:09:38 EDT
It seems to be related to warning in s390x build logs:

gssapi.c: In function 'gssapiv2_server_plug_init':
gssapi.c:1424:2: warning: implicit declaration of function 'gsskrb5_register_acceptor_identity' [-Wimplicit-function-declaration]
  gsskrb5_register_acceptor_identity(keytab_path);
Comment 13 Ludek Smid 2014-06-13 06:19:42 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.