Bug 1002632 - [RFE] can rpmdev-diff give me differences in the linked libraries for binaries
[RFE] can rpmdev-diff give me differences in the linked libraries for binaries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmdevtools (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 11:52 EDT by jcpunk
Modified: 2013-08-31 16:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 16:00:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jcpunk 2013-08-29 11:52:18 EDT
Description of problem: It would be nice if rpmdev-diff could also give me the differences for linked libraries of binaries.  The 'binary files differ' doesn't tell me if it is because of how they were stripped or because they are linked differently.


Version-Release number of selected component (if applicable):rpmdevtools-8.3-5.fc20


How reproducible: 100%


Steps to Reproduce:
1. rpmdev-diff <binary rpm1> <binary rpm2>
2. try and see if the difference in the binaries is relevant to me or not
3. can't

Actual results:
differences are always reported, but I can't get more detail

Expected results:
a way of getting more detail about the differences between the binaries

Additional info:
Comment 1 Ville Skyttä 2013-08-31 16:00:24 EDT
That's out of scope for rpmdev-diff. But I gather at least some of what you're looking for is available in rpmdiff (in the rpmlint package) and rpmsodiff (in the rpmdevtools package).

Note You need to log in before you can comment on or make changes to this bug.